Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have two machines running FreeBSD, bsdclient and bsdserver. I am trying to setup remote logging such that bsdclient sends all the logs to bsdserver. My syslog.conf on bsdclient goes like this

*.*        @bsdserver.domain.com

On bsdserver, the syslog.conf is configured as:

+bsdclient.domain.com
*.*        /var/log/bsdclient.log

syslogd in bsdserver was started in rc.conf as:

syslogd_enable="YES"
syslogd_flags="-a bsdclient.domain.com"

To test, on bsdclient i did

logger -p auth.info "user authenticated"

I can see entry in the /var/log/auth.log on bsdclient, however there is nothing in the /var/log/bsdclient.log on bsdserver. I am trying to send all type of logs to bsdserver. Did i make any mistake?? Thanks in advance

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

is bsdclient.domain.com and bsdserver.domain.com global DNS aware ? If not have you tried putting in an IP instead of DNS names.

Please following this excellent handbook section from freebsd handbook

share|improve this answer
    
the machines are not connected to any other network, it's just a network between two machines and the domains are well configured. There is no problem accessing two machines with their domain. However, i've even tried with their IPs, no luck.. Could you suggest any way I can debug the whole thing?? –  suenda Feb 6 '12 at 14:04
add comment

First of all, turn on verbosity on the server:

syslogd_flags="-a bsdclient.domain.com -v -v"

And on the client:

syslog_flags="-s -v -v"

That'll give you more information.

Have you configured a logging facility on the client yet, to tell syslog what to log? To find out more about it look at the aforementioned Handbook and the syslog Manpage

share|improve this answer
    
thanks for the reply, it still does not solve the main problem.. –  suenda Feb 7 '12 at 19:10
    
Well, with the added verbosity you should get some more information on what is going on, though. Because right now, you kind of give no information at all, which doesn't make debugging this any easier. –  juwi Feb 7 '12 at 20:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.