Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I use a VPS with Ubuntu 10.04. After I performed "apt-get upgrade", the ssh daemon stopped working and does not automatically start when I restart my server. I have only access to files (edit, create delete etc.) and no shell access. Could you please help me out with setting up SSH Daemon autostart? Thank you very much.

share|improve this question
    
If you can edit files, you can access the log files. Are there any informations in /var/log/syslog? –  SvW Feb 6 '12 at 13:56
    
For what should I look for inside the log file? –  Paris Feb 6 '12 at 14:15
    
Anything that looks related to the failed start of the SSH daemon. –  SvW Feb 6 '12 at 14:18
    
ssh or sshd are referred nowhere inside the file. –  Paris Feb 6 '12 at 14:19
    
you should look inside /var/log/auth.log ...should give TIMESTAMP SERVERNAME sshd[8355]: Server listening on 0.0.0.0 port 22. TIMESTAMP SERVERNAME sshd[8355]: Server listening on :: port 22 on successful startup of sshd daemon –  kaji Feb 6 '12 at 14:28

1 Answer 1

I am afraid without shell access, there is little we could do to diagnose the problem. Does your VPS comes with control panel of any sort ? if they do provide that , their should be direct console access from there otherwise you will have to contact a support person from VPS company that has direct access to the server.

share|improve this answer
    
I use the Virtuozzo Control panel, but it does not give me shell access. –  Paris Feb 6 '12 at 14:04
    
I don't have any experience with virtuozzo control panel. Best option would be to contact the person who has a physical access to the machine which hosts the VPS in your case. –  kaji Feb 6 '12 at 14:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.