Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a brand new cisco router 3925/k9. I wanted to set up a router on a stick on my network, but it turns out it doesn't support vlan sub-interfaces. I did it multiple times in gns3 simulator on other routers, so I am familiar with IOS commands and concepts. I believe this must be a licensing issue, but so far I couldn't find anything on cisco website that explains it. Here is some info from "show version":

ROM: System Bootstrap, Version 15.0(1r)M13, RELEASE SOFTWARE (fc1)
System image file is "flash0:c3900-universalk9-mz.SPA.151-4.M2.bin"
3 Gigabit Ethernet interfaces
1 terminal line
1 Virtual Private Network (VPN) Module
DRAM configuration is 72 bits wide with parity enabled.
255K bytes of non-volatile configuration memory.
250880K bytes of ATA System CompactFlash 0 (Read/Write)

License Info:
-----------------------------------------------------------------
Technology    Technology-package           Technology-package
              Current       Type           Next reboot
------------------------------------------------------------------
ipbase        ipbasek9      Permanent      ipbasek9
security      securityk9    Permanent      securityk9
uc            None          None           None
data          None          None           None

I would appreciate if anyone could give me a clue what I can do to enable vlan support on this router.

share|improve this question
    
Why haven't you just asked Cisco Tech Support? –  the-wabbit Feb 6 '12 at 21:11
1  
According to the feature navigator your router should support 802.1q VLANs. What config are you trying to enter? Is it encapsulation dot1q <xx> under the subinterface? –  resmon6 Feb 7 '12 at 14:57

1 Answer 1

up vote 0 down vote accepted

cisco router 3925/k9 fully supports 802.1q VLANs. The problem was lack of my attention. I totally forgot that encapuslation dot1q is available in subinterface and not the main interface. so the correct config for enabling vlans on cisco router should look like this:

Router_A(config)#interface fastethernet 0/0
Router_A(config-if)#no shutdown
Router_A(config-if)#interface fastethernet 0/0.1
Router_A(config-subif)#encapsulation dot1q 1
Router_A(config-subif)#ip address 192.168.1.1 255.255.255.0
Router_A(config-if)#interface fastethernet 0/0.2
Router_A(config-subif)#encapsulation dot1q 10
Router_A(config-subif)#ip address 192.168.5.1 255.255.255.0
Router_A(config-if)#interface fastethernet 0/0.3
Router_A(config-subif)#encapsulation dot1q 20
Router_A(config-subif)#ip address 192.168.7.1 255.255.255.0
Router_A(config-subif)#end
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.