Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working on setting up a server running Plesk 10.4.4 Update #13 on Centos 6.2.

I've configured Mailman and now I want to set up some mailing lists. I've created a list in the Plesk control panel, but when I try to administer the new list (by visiting http://lists.[domain].com/mailman/admin/[listname] I see the following error:

Bug in Mailman version 2.1.12

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

I see exactly the same error if I try to go to the list info page at http://lists.[domain].com/mailman/listinfo/[listname].

I would follow the instructions and look in the error logs, but I can't find them. I would expect to find a file at /var/log/mailman/error, but there's nothing there.

My test list seems to work correctly. It sends all the expected email. It's just the web pages for the list that seem to be broken.

Has anyone else seen this? Any suggestions for tracking down and fixing the problem?

p.s. I think I've chosen the correct Stack Exchange site, but it this question would be better asked elsewhere, please let me know.

Update: I got to the bottom of this, so I'm documenting the answer in case anyone else has the same problem.

The fact that I couldn't find the error log was the clue. The problem was that the Mailman process didn't have permissions to create an error log. And it seems that if Mailman can't create an error log then it will respond to any web request with this error page. Creating an error log file (in /var/log/mailman/error) and giving it the correct permissions fixed the problem.

share|improve this question
1  
You'd need to start by tracking down the actual error that is occurring (in the Mailman logs). All you're basically saying is 'this is broken', but not actually indicating what is broken, or how it's broken. –  devicenull Feb 7 '12 at 1:19
    
Yeah, I know it's not much to go on. But as I said in the question, I can't find the mailman logs to give any more details. I guess I was basically hoping that someone would say "oh yeah, I remember. That happened to me too - here's how I fixed it". –  davorg Feb 8 '12 at 8:43
    
I'm facing the same problem with mailman 2.1.9, in my case the cause seems to be that the mailman installation has run out of available disk space. –  S.L. Barth Jan 20 at 16:43
add comment

migrated from webmasters.stackexchange.com Feb 6 '12 at 23:51

This question came from our site for pro webmasters.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.