Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Whenever I e-mail "root", I want it to be forwarded to root@example.org (instead of a local delivery).

However, I keep getting this:

Feb  9 17:41:54 botmaster postfix/smtp[29969]: B6E0B808F5: to=<root@botmaster.corp.flatturtle.com>, relay=none, delay=0.01, delays=0.01/0/0.01/0, dsn=5.4.6, status=bounced (mail for botmaster.corp.flatturtle.com loops back to myself)

This is my main.cf:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (by FlatTurtle)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file=/etc/ssl/certs/ssl-cert-snakeoil.pem
smtpd_tls_key_file=/etc/ssl/private/ssl-cert-snakeoil.key
smtpd_use_tls=yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = mx.flatturtle.com
#alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
local_transport = error:local delivery is disabled
mydestination = localhost
relayhost = 
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 172.27.0.0/18 85.12.6.130/32
#mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
relay_domains = /home/mx/postfix_transport
unknown_local_recipient_reject_code = 550 

smtpd_recipient_restrictions =
        permit_sasl_authenticated,
        permit_mynetworks,
        reject_unauth_destination,
        reject_unauth_pipelining,
        reject_rbl_client sbl-xbl.spamhaus.org,
        check_policy_service unix:private/postgrey,
        permit

There are a few ways to disable local delivery, but none of them seem to be working (or at least, I keep getting that message).

dig mx flatturtle.com:

flatturtle.com.     14679   IN  MX  30 mx.flatturtle.com.
flatturtle.com.     14679   IN  MX  10 mail.flatturtle.com.

dig mx.flatturtle.com:

mx.flatturtle.com.          604800  IN  CNAME   mail2.rootspirit.com.
mail2.rootspirit.com.       21600   IN  CNAME   one.rootspirit.com.
one.rootspirit.com.         21600   IN  A       95.211.44.129

dig mail.flatturtle.com:

mail.flatturtle.com.    444387  IN  CNAME   mail.rootspirit.com.
mail.rootspirit.com.    10265   IN  A       85.12.6.130

dig flatturtle.com:

flatturtle.com.     14594   IN  A   85.12.6.130

dig botmaster.corp.flatturtle.com:

botmaster.corp.flatturtle.com. 4680 IN  A   95.211.44.129
share|improve this question
add comment

3 Answers

"mail loops back to myself" has only one cause: postfix is sending out mail to a recipient domain that it is responsible for, such as RCPT TO: me@example.org, while $myhostname is the MX for example.org.

There is no configuration to fix this, since it is what you configured.

Add an alias for root to somewhere NOT on your postfix box, such as:

root:  you@other.example.com
share|improve this answer
    
This server is a backup MX server for about 150 domains (including "domain.tld"). $myhostname is actually set to servername.corp.domain.tld, /etc/alias is set to: root: root@domain.tld –  Tuinslak Feb 7 '12 at 17:34
add comment

Postfix doesn't permit to send email to a destination SMTP server that have the same myhostname in SMTP banner. Then you must set current myhostname to backup.example.org or something else.

myhostname is a machine name, to avoid this problem you could set the MX server name to 'dexter.example.org' and the backup server name to 'deedee.example.org'. RFC 1178 says 'Use theme names'.

share|improve this answer
    
That's actually the case: "myhostname = botmaster.corp.flatturtle.com" (I should've been more clear with "example.org") –  Tuinslak Feb 8 '12 at 22:40
    
Then you trying deliver by smtp to local IP. Check the DNS record for 'example.org' (test dns query from backup server) must point to primary server. –  Reinaldo de Carvalho Feb 9 '12 at 11:49
    
I've edited the original post with dig information (and used the real domains this time to avoid any more confusion). –  Tuinslak Feb 9 '12 at 17:21
    
when you send mail to 'user' without the domain, postfix add the value configured in option 'myorigin'. The alias_maps option is used to only by MDA 'postfix/local'. If you are senting mail by smtp, alias_maps isn't evoluated. –  Reinaldo de Carvalho Feb 11 '12 at 16:58
    
do not comment mydestination because the default value is $myhostname value. (use 'postconf -d mydestination' to see the default value). mydestination domains is locally delivered mails. –  Reinaldo de Carvalho Feb 11 '12 at 17:02
show 7 more comments
up vote 0 down vote accepted

I've found a work around by creating a new domain on the nameserver: "botmaster.corp.flatturtle.com".

The MX records point to another SMTP server.

Thus mailing root (which adds the @botmaster.corp.flatturtle.com domain) is forwarded and correctly delivered.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.