Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm looking to compile a custom kernel from the official source tree (kernel.org). The machine itself runs the latest stable RHEL kernel without issues but I can't seem to figure out why it's panicking on any stock kernel. I suspect it's a driver issue however I'm relatively new at debugging this.

The kernel attempted to compile with a stock config is 2.6.32.55. I've also attempted to compile it with the previous working kernel config to no avail.

The machines specs are as follows:

  • Motherboard: SuperMicro X9SCI-LN4F Intel Xeon SingleProc SATA
  • CPU: Intel Xeon-SandyBridge E3-1270-Quadcore
  • RAID-1 with an Adaptec 5405Z controller
  • Drives: Seagate Cheetah

When trying to boot into the stock kernel it panics on the device-mapper initialization leading me to believe it was an issue with the RAID driver. It appears the stock kernel has the latest aacraid drivers although I've attempted to re-compile the kernel with the latest from adaptec.com with the same issue.

Here is the stack trace I'm receiving. Any information as to how to further debug this would be greatly appreciated. Thanks!

https://s3.amazonaws.com/uploads.hipchat.com/9460/23303/80l8xsnfl7fa7e9/panic2.png

share|improve this question

2 Answers 2

up vote 2 down vote accepted

"Attempted to kill init" messages are usually caused when it cant find /sbin/init (or it cant execute it).

Double check your root= parameter in your bootloader config and make sure its pointing to the device for your / partition, and not /boot or anywhere else by accident.

Edit: Redhat also uses a initrd, so this could be another point of issue. So if you have a initrd configured, make sure /init exists in it (the kernel looks for /init when using initrd/initramfs and /sbin/init when not)

share|improve this answer
    
Thank you - this is pretty much how I started to debug it and eventually found the kernel config option mentioned in my answer which solved the issue. –  WinkyWolly Feb 9 '12 at 21:03

I was able to figure out the issue. After getting more verbose output (with assistance from SoftLayer support, kudos to them) it was showing issues with setuproot. It appears the following kernel config option needed to be set to enable old-style SYSFS stuff

CONFIG_SYSFS_DEPRECATED_V2=y

After that the kernel booted as expected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.