Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Running 11.04 and I downgraded down to php5.2 due to some needs. I don't remember how. I'd like to get back up to 5.3 now. I'm trying to use apt-get upgrade but I get the following messages:

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 krb5-multidev : Depends: libkrb5-3 (= 1.8.3+dfsg-5ubuntu2.2) but 1.9.1+dfsg-1ubuntu2.2 is installed
 libgssapi-krb5-2 : Depends: libkrb5-3 (= 1.8.3+dfsg-5ubuntu2.2) but 1.9.1+dfsg-1ubuntu2.2 is installed
 libkrb5-3 : Depends: libk5crypto3 (>= 1.9+dfsg~beta1) but 1.8.3+dfsg-5ubuntu2.2 is installed
             Depends: libkrb5support0 (= 1.9.1+dfsg-1ubuntu2.2) but 1.8.3+dfsg-5ubuntu2.2 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

I'm not having any luck finding any leads on how to fix.

Let me know if I should provide more information.

EDIT: adding listing of /etc/apt/preferences.d

:/etc/apt/preferences.d$ ll
total 12
drwxr-xr-x 2 root root 4096 2011-10-15 11:14 ./
drwxr-xr-x 6 root root 4096 2012-02-07 23:39 ../
-rw-r--r-- 1 root root  738 2011-10-15 11:14 php

Listing of /etc/apt

/etc/apt$ ll
total 76
drwxr-xr-x   6 root root  4096 2012-02-07 23:39 ./
drwxr-xr-x 161 root root 12288 2012-02-09 09:36 ../
drwxr-xr-x   2 root root  4096 2011-11-29 10:47 apt.conf.d/
drwxr-xr-x   2 root root  4096 2011-10-15 11:14 preferences.d/
-rw-------   1 root root     0 2011-04-25 18:52 secring.gpg
-rw-r--r--   1 root root  3277 2012-01-02 20:14 sources.list
drwxr-xr-x   2 root root  4096 2012-01-03 09:44 sources.list.d/
-rw-r--r--   1 root root  3277 2012-01-02 20:14 sources.list.save
-rw-------   1 root root  1200 2012-01-02 20:05 trustdb.gpg
-rw-r--r--   1 root root 13937 2012-01-02 20:05 trusted.gpg
-rw-r--r--   1 root root 13937 2012-01-02 20:05 trusted.gpg~
drwxr-xr-x   2 root root  4096 2011-04-07 07:13 trusted.gpg.d/
share|improve this question

1 Answer 1

up vote 0 down vote accepted

this may be caused by held packages

Yep, that's probably it. aptitude is a very handy interactive cli tool for installing packages and also for investigating when odd things happen.

Try it out, it'll likely tell you what's wrong (or what breaks when you try and upgrade php).

share|improve this answer
    
Thanks. I do not have aptitude installed and when I try to do so, I get an error that the package system is broken and nothing else can be installed without that being fixed. I don't know if downloading the .deb and installing that way is a workaround. Thoughts? –  caelon Feb 8 '12 at 19:42
    
You should probably post the contents of /etc/apt/preferences and look for any non-standardness in /etc/apt/. –  MikeyB Feb 9 '12 at 14:28
    
Update - I have discovered I do have aptitude. It wasn't showing as installed using Software Manager - that's what I get for trusting a GUI. Let me go play with that now. –  caelon Feb 9 '12 at 21:14
    
I just reinstalled Ubuntu 11.04 to deal with it. Thanks for the help. –  caelon Feb 11 '12 at 19:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.