Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have Windows Server 2008 R2 as host and Installed Ubuntu 11.04 as Virtual Machine using Virtual Box. My proxy is configured using URL. I tried configuring in the networking settings and also with Firefox's preference page. But both did not work. How to solve this issue? I have configured the VM using default NAT option.

enter image description here

share|improve this question
    
If you are in NATed mode, proxy configuration is not needed as it will not be able to see traffic coming from Guest OS(Ubuntu) directly. It will see traffic from Host OS(Windows) which is doing on behalf of Guest OS. –  kaji Feb 8 '12 at 11:01
    
Have you confirmed connectivity to your proxy? –  Garry Harthill Feb 8 '12 at 11:02
    
host is able to connect to the internet with the preferred configuration but the guest can't detect it I guess. I changed to No Proxy configuration but still it's not working –  sarat Feb 8 '12 at 11:30

2 Answers 2

Switch the network adapter (in VMWare or Virtualbox) to use bridged mode. Then the VM will get a DHCP address from your home router directly, rather than from the vm internal NAT DHCP server, and it will have the same access as the computer that is running the virtual machine.

share|improve this answer
    
I tried bridging as well. I think the virtual interfaces aren't up! It's not working :( –  sarat Feb 9 '12 at 6:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.