Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set a mail server up on my freebsd 7 virtual host. But when I try to send or revive an email the log files tell me 'connection refused':

Feb  8 17:54:42 vps-id2247 postfix/error[29886]: 2A9E044A96F: to=<myemailaddress@gmail.com>, relay=none, delay=2165, delays=2165/0.01/0/0.03, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)


add allow ip from any to any via lo0
add allow icmp from any to any
add allow tcp from any to me dst-port 22 in
add allow tcp from me 22 to any out
add allow tcp from any to me dst-port 21 in
add allow tcp from me 21 to any out
add allow tcp from any to me dst-port 80 in
add allow tcp from me 80 to any out
add allow tcp from any to me dst-port 25 in
add allow tcp from me 25 to any out
add allow tcp from any to me dst-port 110 in
add allow tcp from me 110 to any out
add allow udp from any to me dst-port 53 in
add allow udp from me 53 to any out
add allow tcp from any to me dst-port 53 in
add allow tcp from me 53 to any out
add allow tcp from any to me dst-port 443 in
add allow tcp from me 443 to any out
add allow tcp from any to me dst-port 10000 in
add allow tcp from me 10000 to any out
add allow tcp from any to me dst-port 143 in
add allow tcp from me 143 to any out
add allow tcp from any to me 49152-65535 in
add allow tcp from me 49152-65535 to any out
add allow ip from any to any out keep-state
add deny ip from any to any

so to exude that it's not the firewall I was wondering if these settings are good. note I'm using the standard ports ( 25, 143 ) and telnet on port 25 tough the domain url says 'hello'

share|improve this question
    
your firewall settings seems right, check this zimbra.com/forums/users/… –  user993553 Feb 8 '12 at 23:37
    
turns out my amavis / clamd was not running thanks! could you add that as answer so I can accept it? –  FLY Feb 9 '12 at 9:49

1 Answer 1

up vote 0 down vote accepted

The firewall settings were ok.

amavis / clamd were not running.

More info here: link.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.