Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

UPDATE BELOW: UPDATE 2 BELOW: FINAL Solution

I have a brand new HP EliteBook notebook 8560p running Windows 7 64bit. I plug it into a small Dlink di-604 router, it is currently configured with DHCP and gets ip address 192.168.1.100, ip address of the router is 192.168.1.6. I plug a second notebook in and it gets ip address 192.168.1.101. This is all that is plugged in and the router is not connected to the WAN. If I go on the second notebook (.101) and ping the first (.100) it does not respond. If I try pinging 192.168.1.2 ( a non existent IP address) I get a response and I notice in the arp cache that the MAC address of the first machine is listed for ip 192.168.1.2 and 192.168.1.100. No where on the first machine is 192.168.1.2 defined, nor has it ever been, this is a bone stock straight out of the box notebook. ipconfig /all responds with 192.168.1.100 and 192.168.1.150 respectively.

I tried setting the first machine to a static address 192.168.1.150. Again same results, cannot ping .150 however response to ping .2. , .2 and .150 show up in the arp cache of .101 with the same the same MAC address.

Some observations: when responding to pings on .2 it is not consistently <1ms or less it is usually a fairly high ranging number, anywhere from 4ms to 30ms, which is really odd considering both are connected to the same switch.

I have tried multiple routers, dlink, sonicwall, and another dlink. Same result on all

If I use a different subnet for the entire lan, like 192.168.0.x instead of 192.168.1.x there is no problem what so ever it works and responds as expected.

Anyone ever see anything like this before?

UPDATE: I had a continuous ping running to this mysterious IP address 192.168.1.2 and when i rebooted the troubled machine the ping started back up as soon as the BIOS came up. I did some research, looks like HP included some Intel tool called Intel AMT or CIRA. This tool has the 192.168.1.2 hard coded into it. No where in the BIOS can I find an option to change this to either DHCP or disable it (we certainly don't want this product). Anyone know how to get rid of this?

UPDATE 2: I can't post an answer but here is the solution: Problem was caused by Intel AMT or vPro. You can disable this in the BIOS however it isn't straight forward. In the BIOS go to system configuration->AMT options. Once there turn on Verbosity Options, then you can turn on "Enable AMT unconfigure on next boot" Once you do that it clears all the AMT settings (password, et all ). You can follow this guide here http://h10032.www1.hp.com/ctg/Manual/c01954655.pdf if you want to use AMT. thanks for all your help. Also wanted to say HP support was useless they didn't even know that model had AMT nor how to disable/reset it. However after I did talk to them and bring this problem to their attention they said they would be posting a document on their website shortly.

share|improve this question
    
You're not behind Carrier Grade NAT on your interet connection are you? E.g. Your public ip address in the router really is public, not 10.x.x.x? –  Mark Henderson Feb 8 '12 at 19:08
    
Must have missed that, it is a very small statement inside a large block of text (and I was on my iPhone) –  Mark Henderson Feb 8 '12 at 19:28
    
No worries, totally understand. I think I have found the culprit, will update message. –  ethermal Feb 8 '12 at 19:40
3  
I don't think what I'm going to say justifies a real Answer, but if its that new of a laptop, contact HP. They'll tell you how to disable it. –  JohnThePro Feb 8 '12 at 19:56
4  
@ethermal, if this is the answer, add it as an answer and accept this. It is OK to do this here. –  uSlackr Feb 8 '12 at 22:03
show 6 more comments

2 Answers

From the comments

Problem was caused by Intel AMT or vPro. You can disable this in the BIOS however it isn't straight forward. In the BIOS go to system configuration->AMT options. Once there turn on Verbosity Options, then you can turn on "Enable AMT unconfigure on next boot" Once you do that it clears all the AMT settings (password, et all ). You can follow this guide here h10032.www1.hp.com/ctg/Manual/c01954655.pdf if you want to use AMT.

share|improve this answer
add comment

I was experiencing this same issue with a new HP EliteBook notebook 8560p claiming the 192.168.1.2 IP address. In my case however, it was a much more frustrating issue as we also had a file server operating on the same IP. Anyway, I wanted to point out two bits of useful information here.

  1. Even if completely powered off, but still connected to AC and LAN the management board is still active and will still respond to pings.
  2. At least in my case, turning on "Enable AMT unconfigure on next boot" did NOT clear the AMT Manageability Engine password or IP settings and for some reason the password was something other than the default "admin'. Ultimately, to get the AMT ME settings to clear, I had to clear the BIOS settings by disconnecting the CMOS battery.

Just as a side note, it looks like if the affected machine has an EFI BIOS you may have to trip a jumper to clear the AMT ME settings. Details on that here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.