Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a locally hosted website that uses Smarty templates, I'm trying to get started on building an API for the site.

I've used to create a local virtual host for this and other sites.

I've discovered that if I put a directory called api at the root of any of these virtual hosts I will get a 503 error when I try to access anything inside.

I am using mod-rewrite but so far only to append a .php extension when needed.

Here are the error logs for a request:

[Thu Feb 09 13:42:37 2012] [error] proxy: HTTP: disabled connection for (localhost)
[Thu Feb 09 13:49:06 2012] [error] (61)Connection refused: proxy: HTTP: attempt to connect to [fe80::1]:8080 (localhost) failed
[Thu Feb 09 13:49:06 2012] [error] ap_proxy_connect_backend disabling worker for (localhost)

The middle line gave me a clue to look in my hosts file because why would a request go to [fe80::1]:8080? I commented out that line and tried again, this time the error was in connecting to the standard localhost.

I have concluded that perhaps there is some config file somewhere picking up the underlying request of localhost/api and pointing it somewhere other than my virtual host. At this point my ability to fix the problem fails me. Can anyone help?

share|improve this question

The proxy configuration is trying to pass the request to localhost:8080. Whatever destination server is not accepting requests on port 8080

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.