Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I apologize in advance for my ignorance. We just switched from Fedora 8 to Fedora 15. I would like to make gnome-fallback the default desktop environment for all users. Via google I've found that:

$ gsettings set org.gnome.desktop.session session-name 'gnome-fallback'

will set it for the current user only. I've done a little reading about Gconf and gconf-tool2.

Apparently there's a way to make gconf settings default for all users, but I don't see how gconf associates to gsettings.

What am I missing?

Here's some additional information about what I'm trying to do:

I'm creating a Fedora liveCD which is stripped down for my application. The liveCD needs to come up in gnome-fallback and then every user after that to also use gnome-fallback by default.

I have a service that runs on the liveCD it can run any shell commands that are required.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Use this command (as root, from a console to avoid the per user setting):

dbus-launch gsettings set org.gnome.desktop.session session-name 'gnome-fallback'

From: http://fedorasolved.org/Members/bookwar/gnome-3-tips/

share|improve this answer
    
Thanks for your reply and sorry for the delay getting back to you, but this is not working for me. I didn't see any mention to dbus-launch on the link you provided. Could you describe how this works? –  user800133 Feb 14 '12 at 0:00
    
Sorry, fixed the link. Basically it does a connect to dbus if it's not running to do its work. –  AndreasM Feb 14 '12 at 6:37
    
If I log in as root and run dbus-launch gsettings set org.gnome.desktop.session session-name 'gnome-fallback' It changes the session-name property for the root user, but does not change it for all users. –  user800133 Feb 14 '12 at 15:44
    
I found this page: live.gnome.org/dconf/SystemAdministrators maybe you can do this: Go to /etc/dconf/db/gdm.d, look at the 00-upstream-settings and make an 01-sessionname file with a [org/gnome/desktop/session] section with the key session-name='gnome-fallback' and then a dconf update as root. –  AndreasM Feb 14 '12 at 16:08
    
Thanks AndreasM! I did something very similar to what you described. The only difference was I decided to create my own profile. It worked beautifully! This link is very similar. –  user800133 Feb 14 '12 at 22:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.