Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a little (virtual) infrastructure with multiple servers - and some of these configuration I cannot change because of software restrictions. 2 of the servers are WEBservers, and a NAS-like server. In front of the webserver is a load-balancer (not question related, but for understanding).

The NAS has mounted a partition regurarly for files I'd like to serve the webservers. So I set up a NFS-share on it which is accessible by the webservers. In this way I can ensure that both webservers have the same files and I don't have to sync them in any way. For big files I'd like to mount an additional ressource inside the existing NFS share on the NAS (to be able to save them somewhere externally or for use with Amazon's A3). In my test setup I did just another partition and mounted it inside in a subfolder.

In the end, my NAS has a NFS share at let's say /mnt/data. In the NAS I have mounted the external ressource into /mnt/data/external. On the NAS server is everything fine. But when I take a look from the webservers view I cannot see the contents of folder 'external'. Also the mounted space size has not been increased.

Is my idea something impossible or am I missing something?

I'd like to see and manipulate files in that second mount from the webservers. A bit an odd configuration heh? Because of some restriction of the virtualisation software I have to do this like that. What I cannot change is the setup of the nfs-share for the connection between webservers and nas. So I try to find a way to include the external ressource inside it.

Thanks very much for any help!

share|improve this question
add comment

1 Answer

You want to take a look at the nohide option. As the manpage for exports says:-

This option is based on the option of the same name provided in IRIX NFS. Normally, if a server exports two filesystems one of which is mounted on the other, then the client will have to mount both filesystems explicitly to get access to them. If it just mounts the parent, it will see an empty directory at the place where the other filesystem is mounted. That filesystem is "hidden".

...which seems to describe exactly the behaviour you're seeing.

Adding nohide as an option to the export in /etc/exports should solve this.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.