Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am a little confused about what is going on here. I've tried to diagnose the situation with Google to no avail. I want to get this working as well as understand what is wrong. Basically I am trying to enable ssl on a remote ubuntu 11.10 apache server. I'm currently using the snakeoil certs just to get everything working and then I will switch to a trusted cert. Scanning 443 shows that it is open on the server.

When I ssh in and run this command

openssl s_client -connect localhost:443

everything looks fine. But when I run this command remotely

openssl s_client -connect www.mydomain.com:443

I get this error

CONNECTED(00000003)
10576:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol:s23_clnt.c:607:

The port is open and being forwarded correctly. What gives?

share|improve this question
    
Have you tried to do a simple tcpdump? Do you see the packets from the remote system? Does it do a TCP hand-shake? –  Zoredache Feb 10 '12 at 20:54
1  
Try opening mydomain.com:443 in a web browser to see if perhaps apache is serving http on the https port for that ip address. –  stew Feb 10 '12 at 20:56
    
Yeah, something's out of whack - tcpdump is a good place to look. Is it trying to hit the correct interface IP when www.mydomain.com is resolved - or is it a public address that's NAT'd to an interface IP? –  Shane Madden Feb 10 '12 at 21:09
1  
What do you mean by "The port is open and being forwarded correctly"? Is there some other layer between the Internet and your web server? –  cjc Feb 10 '12 at 21:19
1  
Can you show the VirtualHost and NameVirtualHost configurations? –  cjc Feb 11 '12 at 1:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.