Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I run mtr --report tokyo1.linode.com I see the following report. It looks like my traffic is bouncing around inside my local network 12 times even before hitting the "internet". Any idea what could be causing this and how I could troubleshoot it?

My computer is connected via wi-fi to a router, the router is hooked up to a dsl connection by a socket in the wall. There is NO modem between my router and the connection in the wall. This is my first time using a broadband provider that doesn't need to use a modem but somehow it works.

Please note I replaced some numbers with R and Q in the report below just to be safe.

HOST:         MacBook-Pro.local   Loss%   Snt   Last   Avg  Best  Wrst StDev
 1.|-- 10.0.0.1                    0.0%    10    0.7   0.9   0.7   1.3   0.2
 2.|-- 10.84.0.1                  80.0%    10    2.9   3.3   2.9   3.7   0.5
 3.|-- 192.168.R.73               80.0%    10    2.1   2.7   2.1   3.2   0.8
 4.|-- 192.168.R.10               80.0%    10    2.0   2.2   2.0   2.4   0.3
 5.|-- ???                        100.0    10    0.0   0.0   0.0   0.0   0.0
 6.|-- 192.168.R.209              80.0%    10   24.7  14.5   4.3  24.7  14.4
 7.|-- 192.168.R.205              80.0%    10    2.3   4.3   2.3   6.2   2.7
 8.|-- 192.168.R.21               80.0%    10    4.5   6.3   4.5   8.2   2.6
 9.|-- 192.168.Q.158              80.0%    10   10.4   6.2   2.1  10.4   5.9
10.|-- bogon                      80.0%    10    2.8   2.4   2.0   2.8   0.5
11.|-- 192.168.R.37               80.0%    10    3.8   4.4   3.8   5.0   0.8
|  `|-- 192.168.R.49
12.|-- 192.168.R.37               80.0%    10   12.5   7.7   2.9  12.5   6.8
13.|-- 124.68.6.189               80.0%    10    4.3   4.7   4.3   5.1   0.5
14.|-- ???                        100.0    10    0.0   0.0   0.0   0.0   0.0
15.|-- 221.122.35.65              80.0%    10    2.7   8.5   2.7  14.2   8.1
... (etc)
share|improve this question
    
Just so you know, you've obfuscated the wrong IP addresses. The first public IP address in your list there you left completely alone, and you changed the internal IP addresses; it should have been the other way around. Additionally, hiding the IP addresses actually achieves very little, just for the record. –  Mark Henderson Feb 12 '12 at 19:29

2 Answers 2

Chances are they are traveling through the network of whoever your service provider is, not your actual network, and you are behind what is called Carrier Grade NAT.

share|improve this answer
    
Thank you so much for the reply! I just tried removing the router and connecting directly. And yes, it still goes through all those 192.x ips. But the difference is that the loss % is almost all 0%. Any idea what I could do to fix things on my end? I guess something is going on w/ my router to cause the packet loss? –  ddf Feb 11 '12 at 7:11
    
@ddf: ICMP is not always a good test of general connectivity. It is quite common for ISPs (especially ISPs that have their end nodes behind NAT) to perform QOS on ICMP traffic. –  kce Feb 11 '12 at 9:21

Tracert isn't a tool for testing connection quality, it's a tool for determining the path between two endpoints. Tracert works by sending ICMP echo requests, incrementing the TTL by one at each successive hop in order to determine the path between the two endpoints. The results show the response from each hop to the ICMP echo request sent TO it, which is not an indication of how that hop is handling "real" traffic sent THROUGH it.

If your results were really showing packet loss THROUGH those hops then each successive hop would show the same packet loss or increasing packet loss.

What you see at the hops that show packet loss is how that hop is responding to the ICMP echo request sent TO it, which in many cases is ignored, dropped, or given low priority. Routers are concerned with routing real traffic, not responding to your tracert.

As such, I don't see an "issue" that needs to be fixed.

EDIT

In answer to your comment:

I should have looked at your trace more carefully. Your trace shows packet loss at the second hop and the same packet loss at each successive hop (the hops showing 100% packet loss are probably ignoring the ICMP packets completely). That may be an indication of a problem. It doesn't explain why removing the router seems to "fix" the packet loss.

share|improve this answer
    
What I find strange is that when I plug in directly (remove the router) the packet loss is almost 0%. As soon as I go through the router I get those high packet losses. So are you saying nothing is wrong with my router and there's nothing to worry about? –  ddf Feb 13 '12 at 3:00
    
See my edit.... –  joeqwerty Feb 13 '12 at 11:43
    
So how do I even begin to try and resolve this? –  ddf Feb 13 '12 at 13:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.