Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to enable Oracle-Managed Files on Oracle Express for Windows XP.

From everything I've read, I need to set db_create_file_dest to an existing directory in the file system.

I've tried setting db_create_file_dest=C:\somedir in init.ora. There appears to be two init.ora files, so I added it to both:

C:\oraclexe\app\oracle\product\11.2.0\server\config\scripts\init.ora
C:\oraclexe\app\oracle\product\11.2.0\server\dbs\init.ora

After restarting the Oracle service (I also tried rebooting Windows), db_create_file_dest is still not set. It would appear that Oracle is not using either init.ora files.

How do I go about setting db_create_file_dest and thereby enabling Oracle-Managed Files?

I am running Oracle Database 11g Express Edition on Windows XP.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Oracle uses two different types of init files.

  1. pfile (text)
  2. spfile (binary)

You changed pfile. But you may need to change spfile. Find if you are using spfile

SELECT DECODE(value, NULL, 'PFILE', 'SPFILE') "Init File Type" 
   FROM sys.v_$parameter WHERE name = 'spfile';

if you are using spfile change this parameter using sql.

ALTER SYSTEM SET db_create_file_dest=..... SCOPE=BOTH
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.