Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Active Directory Domain with a Windows 2003 Standard SP2 Server as the DC. When trying to join an additional Windows 2003 Standard SP2 server to the domain I get message "The following error occurred attempting to join the domain 'My Domain'. The RPC Server is unavailable.

  1. The computer is actually added to the Active Directory Computers. I can even right-click and Manage it.
  2. I can access file shares from the DC on the other server and vice versa.
  3. I can ping the DC from this server and ping the server from the DC using the computer name.
  4. The time on both server is the same more or less to the second.
  5. RPC service is running on both servers.
  6. I can join other computers to the domain and there are no other issues with the domain.
  7. Windows Firewall disabled on both computers.

NetSetup.LOG shows: NetpSetNetloginDomainCache: DSEnumerateDomainTrustsW failed 0x6ba I looked up this WIN32 Error Code: It is RPC_S_SERVER_UNAVAILABLE.

share|improve this question
does local machine show it's a member of the domain? can you ping by fqdn from the DC? if you can join other machines, it's probably an issue with the new server, can you re-image and try again? – jhayes Feb 13 '12 at 21:04
I re-imaged - same result. Found the solution and posted it here. I did not try pinging by FQDN. – Roel Vlemmings Feb 14 '12 at 7:20

Quite a common issue, with lots of possible causes (see Google); the most common one is a DNS resolution problem. Have you double-checked the server is using the DC as its only DNS server?

share|improve this answer

This solved the problem for me.

  1. Right-click My Computer, and then click Properties.
  2. On the Computer Name tab, click Change.
  3. In the Computer Name Changes dialog, click More.
  4. In Primary DNS suffix for this computer, enter the suffix of your domain. Ex. MYDOMAIN.NET.
  5. Click OK. Restart computer.
  6. Join the computer to the domain.

I don't know why this works. I did this on a clean install of Windows 2003 Server and it worked. This is not necessary when adding Windows 7 or Windows XP boxes to my domain, I verified that. But it solved the problem on the Windows 2003 Server box.

share|improve this answer

As others have said, this is a name resolution issue. If you allow NetBIOS over TCP/IP (NBT), your clients will find the domain controller (DC) through NetBIOS broadcasts or WINS. In this scenario, you can join a domain based on its NetBIOS name (e.g.: MYDOMAIN, instead of However, without NBT, your clients must locate the DC through the "proper" method, which is DNS.

When locating a DC via DNS, your client must know which DNS domain to look in. So, you either provide the full DNS domain name when attempting to join, or you configure your client with a primary DNS suffix (as above).

So, long story short:

i) Enable legacy name resolution / resource location (NBT/WINS) ... not recommended or; ii) Join the domain using a fully qualified domain name or; iii) Configure a primary DNS suffix

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.