Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a number of machines scattered around at our clients. The staff habitually unplug the machines causing them to enter Startup Repair mode. When this happens, we need to go on site to cancel the wizard and reboot the machines.

Is there a way to permanently disable Startup Repair and allow the machine to boot normally?

share|improve this question
    
Why does unplugging the power let them enter startup repair in the first place? It typically should not, unless there is some kind of a problem with the startup - which is presumably fixed by the time you get there to cancel the wizard. –  the-wabbit Feb 13 '12 at 14:22
7  
This is a policy problem not a tech problem... Sort out your staff first. the Startup Repair is there for a reason. –  t1nt1n Feb 13 '12 at 14:24
2  
I suggest you use whisky as your workaround here. –  kce Feb 14 '12 at 7:09
    
Have you tried the suggestion by Chris & me? –  Bart De Vos Feb 14 '12 at 7:58
1  
Have you had it run the startup repair? Sounds like something in the filesystem is FUBARed and it detects it at startup to me. You said below that even with this policy set it's still going into repair... –  Bart Silverstrim Feb 14 '12 at 10:46

4 Answers 4

I can't stress Bart's Answer enough. Teach your clients.

If you really want to, this is how:
In cmd, type the following:

bcdedit /set {default} recoveryenabled No
bcdedit /set {default} bootstatuspolicy ignoreallfailures

Be sure to run this in an Administrator shell.

share|improve this answer
    
This has been tried, the problem persists. –  RichieACC Feb 13 '12 at 14:21
    
Typing these into Run wont work unless UAC has been disabled. –  Chris S Feb 13 '12 at 14:23
    
@RichieACC: Be sure to run them in a cmd-shell with elevated rights. Chris, Thanks –  Bart De Vos Feb 13 '12 at 14:28
    
This was tried, in an Administrator shell, and confirmed that the changes were made. When I type bdcedit, it shows: "recoveryenabled No" . Yet, the machine still goes into recovery. –  RichieACC Feb 14 '12 at 8:18

I don't know of a way to disable the startup repair, especially as there are those times where you'd need to use it. In situations like this the real fix is to teach the users NOT to unplug the computers. I don't know why they are habitually trying to destroy the machines, but this is a human behavior problem, not a technology problem.

If you're an outside consultant (you refer to them as clients,) bill them for your time while telling them not to do this. Move where they're plugged in so it's inconvenient to unplug them. Anything to drive home the point to not do that.

Plus, the reason it needs to run startup repair is to make sure the filesystem is in a usable state! You'd want it to check this to prevent corruption. Making them sit through the repair cycle might also drive home the point: DON'T DO THAT.

share|improve this answer
1  
Bart, thanks, but your answer is not useful. I know that it's a human problem, but this is one that we've been trying to deal with for over a year. Your suggestions, although valid, have been tried and have failed. I know the point of startup repair, but you have to admit, it is somewhat paranoid. No, the only viable option is to disable it, and deal with more serious issues when they arise. –  RichieACC Feb 13 '12 at 14:08
3  
@RichieACC You will never solve human problems with technology, you'll only mask some of the symptoms. –  jscott Feb 13 '12 at 14:17
1  
Did you think of putting big signs over the plugs saying DO NOT UNPLUG? –  Bart Silverstrim Feb 13 '12 at 14:23
1  
Or moving the plugs so they're really inconvenient to get to? I'm trying to think of why you have people being hired that think it's okay to turn things off by yanking a cable, which itself isn't smart as it can, rarely, damage the plug/wires themselves. –  Bart Silverstrim Feb 13 '12 at 14:24
1  
@RichieACC Startup repair is not paranoid, it fixes problems for you automatically that you would otherwise need to come and deal with manually. It sounds like there is something wrong with your setup that is encouraging bad habits, you should try and fix the root cause rather than try to ignore the consequences. –  JamesRyan Feb 13 '12 at 14:26

To answer your question directly:

Run a command prompt As Admin, then run:

bcdedit /set {default} recoveryenabled No
bcdedit /set {default} bootstatuspolicy ignoreallfailures

You really should be fixing the user issue too.

share|improve this answer

There are ATX PC power supplies available that have an onboard small UPS, including RS232 driven OS shutdown.

Alternatively, install sockets in lockable fuse boxes, and keep IEC connectors fastened to the machine with brackets.

In both cases, consult with the site electrician before implementing, making it impossible to remove power from equipment might violate local codes.

If a technical solution is really desired, these might be closest to it...

share|improve this answer

protected by Community Nov 2 '12 at 17:06

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.