Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to setup a mailserver but sending and receiving is not working. I can connect to a mailbox using pop3 ( trough telnet and mail client )

When do:

# telnet localhost smtp

the var/log/maillog shows:

postfix/postscreen[3306]: warning: cannot connect to service private/smtpd: No such file or directory

I cannot send anything. Also imap doesn't work and shows the same message Do i need to change the location of private/smtpd and if so how?

as for the telnet repose I get:

421 4.3.2 All server ports are busy
Connection closed by foreign host.

I'm not using chroot here is my /usr/local/etc/postfix/master.cf file

I'm using: freebsd 8.2, postfix 2.8.7

share|improve this question
    
How did you install postfix? How did you start postfix? Does postfix log anything of note when it first starts up? –  larsks Feb 13 '12 at 14:41
    
Installed via ports? Did you allow the service in /etc/rc.conf? If you have not allowed the service, did you run as a runone instance? Did you use /usr/local/etc/rc.d/ to start the services? –  Tim Feb 13 '12 at 14:48
    
Installed trough ports started using postfix start –  FLY Feb 13 '12 at 15:39
    
also I added postfix_enable to /etc/rc.conf and there are no errors shown when I start postfix: postfix/postfix-script[4569]: starting the Postfix mail system postfix/master[4570]: daemon started -- version 2.8.7, configuration /usr/local/etc/postfix –  FLY Feb 13 '12 at 15:48
add comment

2 Answers

up vote 1 down vote accepted

First you should distinguish between dovecot (pop3/imap) and postfix (smtp). So far you only describe a postfix problem.

Does postfix log any errors on (re)start? A possible cause of problems could be a chroot environment... Verify the paths by running postfix check.

Added: Check your postfix main.conf and master.conf (or use postconf -n) to look for non-default path names; and check the queue_directory (by default /var/spool/postfix) which contains the sockets, including private/smtpd. (Dovecot also uses some sockets in the same directory, cf. /usr/local/etc/dovecot/conf.d/10-master.conf, so that seems to be a secondary error with the same cause.)

share|improve this answer
    
The thing is I get the same error (private/smtpd not found) tying to connect with imap. No errors are shown or postfix restart. I'll update my question. Also I've run postfix check which returns no result ( in maillog, and cli ) –  FLY Feb 13 '12 at 15:42
add comment

Check Line

smtpd      pass  -       -       -       -       -       smtpd

in master.cf file

as guided by http://www.postfix.org/POSTSCREEN_README.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.