Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to do a Windows Share for a Supermicro IPMI. I go to "Virtual Media" and then "CD-ROM image". I need to enter:

  • Share to host:
  • Path to Image:
  • User:
  • Password:

I know to enter my Windows 2008 server IP in share to Host, and I entered the Administrator username and password. However, when I enter the path image as C:\Users\Administrator\Desktop\OperatingSystems\CentOS-5.7-x86_64-netinstall.iso I get this

error: The image path is invalid or contain /:*?"<>|

share|improve this question
add comment

2 Answers

I'm not familiar with IPMI, so take this as you wish, but you should probably use an UNC path instead of a drive letter. After all, it's talking about a Windows share.

Try to create a network share on your server, with a path of C:\Users\Administrator\Desktop\OperatingSystems\, and name it OperatingSystems, for example. Then, use the UNC path in IPMI, though I'm not sure in what format the parameters are expected.

share|improve this answer
3  
This is correct. You need to enter a UNC path to the share, so \[sharename]\[folder]\[iso] (you can omit the \\[computer] part as that's taken care of in step #1) –  Mark Henderson Feb 13 '12 at 22:25
    
Perfect, thank you so much! :) –  Jake Feb 14 '12 at 0:02
    
Good to hear that, Jake. If you're satisfied with my answer, don't forget to 'accept' it by clicking the checkmark to the left of it. It's what we strive for. :-) –  Martijn Heemels Feb 15 '12 at 23:22
add comment

The error reported by the web interface is misleading - what it really wants is to have the Path to image: entry beginning with a backslash (\) so it would look like \sharename\filename.iso. The host name (or IP address) in the Share host field has to be entered without backslashes though.

The share has to be an SMB share, but at least the BMC thingy is using NTLMv2 authentication, so it works with current Windows servers out of the box (i.e. without modifying security settings or installing additional software) and presumably should also work with Samba as well.

share|improve this answer
    
Thanks -- this resolved the issue for me. –  Brian Cline Oct 6 '13 at 10:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.