Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When booting my personal code server (Debian Squeeze), the boot screen freezes almost immediately, but when I press a random key (including useless keys such as NumLock) the boot process continues. This happens several times during boot - a random process will stop, continuing only after I press a key.

Once GDM shows up (requiring at least another key press) and I log in, the mouse changes to the "waiting" icon, stopping a couple times until Gnome starts up - from then on, the computer works normally... unless I try to switch to/from a console, in which case I have to (yeah, you guessed it) press a key. This also happens while using gnome-terminal (extra diagnosis: if I try cat /proc/cpuinfo, for instance, the command will hang the first time, but after that it will work flawlessly). This also happens when logging through ssh - if I issue a command on my netbook, and press any key on the server keyboard, the command will get unfrozen immediately.

Finally, this happens too when shutting down the computer (it will show something as "Shutting down Samba", but it continues only after I press a key).

Any ideas about why could this be happening?

Important detail: Sometimes if I don't press any key, after about 15 seconds the system continues doing whatever it was trying to do at the moment (particularly noticeable through ssh, when I'm not near the keyboard and, thus, have no alternative but waiting). This would also explain why Gnome is not as fast as it should (slight delays showing menus, switching programs, and so on).

Extra info:

  • The computer has a 2.6.32-5-amd64 kernel.
  • The video card is an ATI Radeon, but the problem was present both before and after configuring xorg.conf to properly recognize it. Both the video card and the motherboard are Gigabyte.
  • The keyboard is PS/2 (I tried another PS/2 keyboard with no success, and I don't have any USB keyboard available). Plus, ...
  • The computer works fine under Windows XP (32 bits).
share|improve this question
    
I also have the same problem here. I have seen the problem with Debian Wheezy and 3.2 AMD 64 bits kernel and also with Ubuntu 11.10. My machine has an AMD Athlon II processor and I have had 2 differen graphic cards: - HD 6450 and AMD propietary driver with Ubuntu 11.10 - HD 7750 with Open Source radeon driver and Debian Wheezy My motherboard is a Gigabyte 785 series. To it is a kernel issue that can be triggered by some BIOS setting. Which is your prosessor and motherboard manufacturer? Have changed any setting on the BIOS from the deffault ones? –  Kubunteando Jul 22 '12 at 12:56
    
Check this bug: bugs.launchpad.net/ubuntu/+source/linux/+bug/272247 It recommend you add to the booting options of your kernel: "hpet=disable" I just found it so I have not tried it yet. –  Kubunteando Jul 22 '12 at 13:05

2 Answers 2

up vote 1 down vote accepted

Setting acpi=off in grub boot options solved the problen in Wheezy. But that will disable acpi. So I found a better solution that is working for me: Adding to the grub boot options just the option: acpi_skip_timer_override I also disabled hpet Support option in the BIOS but that is not a must.

share|improve this answer

Solved in my case.

I tried to set hpet support option to disabled. But that made Debian not even boot the very begining of the kernel. Then I added in grub boot options: acpi=off Now the issue is gone.

It seems the is typical issue with broken BIOS support for Linux. This is typical in MSI and Gigabyte motherboards. Asus is much better. My next motherboard has to be Asus, it is in my list. In servers it is sometimes not so easy to choose...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.