Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've spent enough time looking around for answers to this with google and I give up. Plenty of discussions about how to build apache with perl support but I want to find out how to tell if the apache that comes with RHEL6.2 already has perl built in. I'm betting is it, but I have an httpd conf file that I've been using on RHEL apache servers since RHEL3 and it always just worked by dropping it into /etc/httpd/conf.d/ but now I tried it on RHEL6.2 and it just lists the source of my script as if perl isn't enabled. I figure the very first step is to verify perl is enabled and then step 2 will be to find out what's wrong with my configuration.

-mark

share|improve this question

2 Answers 2

You can list the loaded modules in the stock RHEL/CentOS Apache with httpd -t -D DUMP_MODULES.

share|improve this answer

Do you have mod_perl installed?

$ yum info mod_perl
Available Packages
Name        : mod_perl
Arch        : i686
Version     : 2.0.4
Release     : 10.el6
Size        : 3.2 M
Repo        : base
Summary     : An embedded Perl interpreter for the Apache HTTP Server
URL         : http://perl.apache.org/
License     : ASL 2.0
Description : Mod_perl incorporates a Perl interpreter into the Apache web server,
            : so that the Apache web server can directly execute Perl code.
            : Mod_perl links the Perl runtime library into the Apache web server and
            : provides an object-oriented Perl interface for Apache's C language
            : API.  The end result is a quicker CGI script turnaround process, since
            : no external Perl interpreter has to be started.
            : 
            : Install mod_perl if you're installing the Apache web server and you'd
            : like for it to directly incorporate a Perl interpreter.

If not, then "yum install mod_perl". It should drop a file in conf.d/ that should load the module.

share|improve this answer
    
excellent, so mod_perl IS installed, which is what I would have expected. In fact I just copied my script to the cgi-bin directory and it does execute, so now for the more exotic because that's now what I want. –  Mark J Seger Feb 14 '12 at 14:38
    
And you have the right ScriptAlias or AddHandler directives in the running configuration? –  cjc Feb 14 '12 at 15:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.