Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hi i'm running a win 2003 server and i need to set up a dns reverse lookup pointer for my mailserver as i'm getting rejected by a certain provider. i created a new reverse lookup zone in the dns manager (default settings) but it seems like there's something wrong with the pointer.

here's what i did:

  • in reverse look up zones -> right click -> new zone
  • selected primary zone
  • network id: added my machine's ip address (the same one which i'm using for connecting via remote desktop)
  • next
  • selected "do not allow dynamic updates" -> finish

then i added a pointer:

  • right click on my new zone
  • new pointer (PTR)
  • host name: entered my (changed) hostname mail.myserver.com -> done
  • right click on my zone -> update server data file + reload

now when testing the dnslookup i keep getting sxxxxxxx.onlinehome-server.info instead of mail.myserver.com :(((

any ideas whats wrong?

thanks

share|improve this question
    
It's doubtful that you're actually doing this in the rDNS zone for the public ip address, which is where it needs to be done... not in your internal rDNS zone. you need to speak to your ISP about setting up the rDNS entry for the public ip address that the email servers is NAT'ed to. –  joeqwerty Feb 14 '12 at 14:29
    
the problem is that i'm admin of the whole server - so i cant ask my isp .. :/ could you maybe give me more detailed info on how to fix this? thanks –  Fuxi Feb 14 '12 at 15:08
    
No, the problem is you're trying to create a PTR entry in your internal rDNS zone when it in fact needs to be created in the rDNS zone for the public ip address that your email sends email from, which is the responsibility of your ISP, since they are the entity that owns the netblock for that public ip address. –  joeqwerty Feb 14 '12 at 16:24
    
joeqwerty is right. You need to contact your ISP and have them create the PTR record for the public IP address your mail server goes through. –  jmreicha Feb 14 '12 at 16:28
    
thanks for your help! it was indeed a global setting my hoster's webinterface .. :D –  Fuxi Feb 14 '12 at 17:29
add comment

1 Answer 1

The person who is responsible for the IP block are the ones who control the reverse lookups. Unless they delegate the blockto you, they own it and lookups goto their servers.

If you are just renting a server, etc and are given a range of IPs they are not delegating the ip block to you.

You need to send a request a reverse entry be added for your server to the group that administers the IP block. Or ask the block assigned to you be delegated to your server. Unless you got the block assigned to you by the regional NIC - you aren't going to be the block owner.

See the spamhaus faq for some more details - spamhaus faq item

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.