Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

According to mount, the file system does not have the ACL option:

$ mount
/dev/mapper/sys_vg-root_lv on / type ext3 (rw)

However, I could still setfacl and getfacl on this file system. Perhaps I'm misunderstanding the ACL option.

I'm using RHEL5 on this system.

share|improve this question
    
Possibly this will be a interview Question, Good to know, thanks. –  user3145837 Sep 25 at 8:07

2 Answers 2

up vote 2 down vote accepted

In RHEL, ACLs are enabled by default for any filesystems configured at install-time. This can be verified with tune2fs -l <device>.

Any filesystems created post-install must either have the acl mount option in /etc/fstab, or have it hard-set with tune2fs -o acl <device>.

share|improve this answer
    
Ah nice to know. tune2fs -l /dev/mapper/sys_vg-root_lv | grep -i 'acl' showed that it was part of the default mount options. –  Belmin Fernandez Feb 14 '12 at 20:02

ACLs are enabled by default on some filesystems like ext3, ext4, and xfs on modern Linux distributions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.