Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am reading MySQL's manuals.

I run

. /usr/local/mysql/bin/mysql                                                                                                                            ~

I get

/usr/local/mysql/bin/mysql:1: command not found: ????^G
/usr/local/mysql/bin/mysql:2: permission denied: 
/usr/local/mysql/bin/mysql:3: parse error near `}'

I run

. /usr/local/mysql/bin/mysqladmin                                                                                                                         ~

I get

/usr/local/mysql/bin/mysqladmin:9: parse error near `)'

These error messages suggest me that my MySQL seems to be corrupted. I did not found by Google explanations for the error messages.

What do the messages really mean?

share|improve this question
up vote 3 down vote accepted

try running


[without the dot]

if you use "dot space" at the beginning file you provide path to will be interpreted as bash-script, but what you point is actual binary executable, not a script.

what you try is NOT the way to start mysql server, those are attempts to run mysql client.

share|improve this answer
I get the error: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/tmp/mysql.sock' (2) – Masi Jul 5 '09 at 9:54
that is much better. do you have mysqld [ mysql server ] running ? – pQd Jul 5 '09 at 9:55
The other command seems to work without "." --- I do not understand how you can run a file without "." – Masi Jul 5 '09 at 9:56
@pQd: I do not have it running, since I have this problem:… – Masi Jul 5 '09 at 9:57
but what you try to run is mysql client [ /usr/local/mysql/bin/mysql ], mysql server is usually called mysqld or mysqld_safe. – pQd Jul 5 '09 at 9:57

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.