Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We a have DebianEDU 5.0.9 codename lenny

Last week it crashed, DHCP I get error:

Cannot find host LDAP entry dhcp (&(objectClass=dhcpServer)(cn=dhcp))

LDAP: no space left on device, cannot be recovered, err 28 .**

First I noticed was that the DHCP server stop functioning and when I tried to restart it I got this error:

tjener:~# invoke-rc.d dhcp3-server start dhcpd self-test failed. Please fix the config file.

The error was:

Internet Systems Consortium DHCP Server V3.1.1

Copyright 2004-2008 Internet Systems Consortium. All rights reserved. For info, please visit http://www.isc.org/sw/dhcp/

Connecting to LDAP server ldap:389

Successfully logged into LDAP server ldap

Cannot find host LDAP entry dhcp (&(objectClass=dhcpServer)(cn=dhcp))

Configuration file errors encountered -- exiting

invoke-rc.d: initscript dhcp3-server, action "start" failed.

I tried following how to repair the error from:

http://wiki.debian.org/DebianEdu/Documentation/Lenny/Upgrades#DHCP_service_needs_to_repaired

  • First the file "/usr/share/doc/dhcp3-server-ldap/dhcpd-conf-to-ldap.pl.gz" didn't exist.

  • So I tried to restart the slapd. didnt give any error but i couldnt reach the lwat website (www/lwat or serverip/lwat)

  • So I tried to repare slapd:

    stop slapd.  invoke-rc.d slapd stop
    check syslog or ps output that it have truly stopped.
    run  sudo -u openldap slapindex 
    

This resulted in:

bdb_db_open: database "dc=skole,dc=skolelinux,dc=no" : unclean shutdown detected; attempting recovery.

bdb(dc=skole,dc=skolelinux,dc=no): unable to join enviroments

bdb(dc=skole,dc=skolelinux,dc=no): write 0x16ca29d0, 8192: No space left on device

bdb_db_open: database "dc=skole,dc=skolelinux,dc=no" cannot be recovered, err 28. Restore from Backup!

bdb_db_close: database "dc=skole,dc=skolelinux,dc=no": txn_checkpoint failed: Invalied argument (22).

backend_startup_one: bi_db_open failed(28)

slap_startup failed

  • I have tried on an virtual server simulating the same error and trying to repair but never managed to recover tried: dkpg-reconfigure slapd --> which resulted in I lost all access to the database.

(reconfigure webinterface) tried dkpg-reconfigure lwat--> which didn't find the database.

tried db4.2_recover -h /var/lib/ldap and restart = no diffrence.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted
LDAP: no space left on device, cannot be recovered, err 28 .

Does your drive actually have free space? If so, is it actually mounted as rw (check the output from the 'mount' command. If it shows up as 'ro', you may have a bad disk)?

share|improve this answer
    
Ah, Noticed the /var was full to the brim with error logs. Deleted them. ran slapindex again ; got the lwat working and could search in the database. But it still couldnt login on clients. The clients couldnt load the kdm. After many hours of troubleshooting i noticed that during my attempts to repaire the ldap i commented out /etc/ldap/schema/dnsdomain2.schema in /etc/ldap/slapd.conf. wish caused that the kdm not to work on the clients. uncommented the line restarted the Slapd = could login again. –  Seb Feb 17 '12 at 9:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.