Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

there's an sbs2008&exchange2007, client is Outlook2010

It's all running with a subdomain (ex. mail.company.com)

so the "sites" are reachable under mail.company.com.

the certificate is selfsigned.

Active Sync with mobile devices is working. autodiscover is working. mail.company.com/owa is working (without certificate issues)

only Problem is a PopUp when starting Outlook2010 -> the third point is a red Cross:

It simplified says "Sites" is not mail.company.com... Any ideas? (I think i have to change Sites to mail.company.com, but i dont know where)

(In Exchange, internal and external url is mail.company.com)

Thanks alot!

edit:

This is not a problem of autodiscover. In "debug"mode from Outlook, i've found this:

https://sites/EWS/Exchange.asmx same for EwsUrl, OOFUrl and UMUrl

where can i change this "sites" to mail.company.com?

edit2

to change the EWS:

[PS] C:\Windows\system32>Set-WebServicesVirtualDirectory -Identity "EWS (SBS Web Applications)" -InternalUrl:https://mail.company.com/EWS/Exchange.asmx
[PS] C:\Windows\system32>Set-WebServicesVirtualDirectory -Identity "EWS (SBS Web Applications)" -ExternalUrl:https://mail.company.com/EWS/Exchange.asmx

edit3

also important:

[PS] C:\Windows\system32>Set-AutodiscoverVirtualDirectory -Identity "SERVER\Autodiscover (SBS Web Applications)" -ExternalUrl:https://mail.company.com/Autodiscover/Autodiscover.xml
[PS] C:\Windows\system32>Set-AutodiscoverVirtualDirectory -Identity "SERVER\Autodiscover (SBS Web Applications)" -InternalUrl:https://mail.company.com/Autodiscover/Autodiscover.xml

edit4

as hint: may be dns takes more than 24-48h for beeing updated in every client

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Did you also modify the autodiscover settings? Outlook makes extensive use of Autodiscover, if that is not configured correctly you get those warnings when starting Outlook. Microsoft has a Knowledge-Base article concerning this issue. Also, if your internal Domain is different from your external Domain you might need to add the external Domain zone to your internal DNS server with internal IPs so the certificate you created is valid for internal and external clients.

To check the autodiscover settings use the DNS Manager. Goto Forward-Lookupzones select your (local) domain, select _tcp there. You should have an SRV-Record (Service Location) in there called _autodiscover. In properties under host it should have a hostname that is in the certificate (office.company.com on SBS i think by default), if that is not the case Outlook will complain about that by telling you that there is a problem with your certificate, if you set it to mail.company.com you should be fine and the certificate-warnings should disappear. For clients pre Outlook 2007 SP1 SRV-records are not used, instead they would use autodiscover.company.com in your case, which should be in the certificate.

To modify the URLs you pointed out you can use two Powershell cmdlets from Exchange Management Shell:

Set-WebServicesVirtualDirectory -Identity "EWS (SBS Web Applications)" -InternalUrl:https://mail.company.com/EWS/Exchange.asmx
Set-UmVirtualDirectory -Identity "UnifiedMessaging (SBS Web Applications)" -InternalUrl:https://mail.company.com/UnifiedMessaging/Service.asmx

The identities should be correct for SBS 2008 default settings, but you should check that it really is in your case. The Set-WebServicesVirtualDirectory cmdlet will take care of EwsUrl and OOFUrl.

share|improve this answer
    
Where should i modify autodiscover? I've configured de Internal DNS correct. External access is only allowed over VPN, so this doesn't matter? –  MemLeak Feb 15 '12 at 14:16
    
I think dns is right, here the nslookup output: > set q=SRV > _autodiscover._tcp.company.com Server: UnKnown Address: xxxx::xxxx:xxxx:xxxx:xxxx _autodiscover._tcp.company.com SRV service location: priority = 0 weight = 0 port = 443 svr hostname = mail.company.com mail.company.com internet address = x.x.x.x > –  MemLeak Feb 15 '12 at 15:39
    
in "Testing AutoConfig"-Mode (from Outlook) are no more site, entries. But finally in protocol is still an sites/Autodiscovery entry. I'll Try to restart the whole Server. Thanks for your help –  MemLeak Feb 15 '12 at 19:43
    
the last entry is gone, i think this last point was a dns-update-delay Problem –  MemLeak Mar 2 '12 at 15:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.