Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Quite simply, what is the easiest and most stable way to replace an apt-get installed PHP 5.2 with the new PHP 5.3 on an Ubuntu 8.10 server?

share|improve this question

4 Answers 4

up vote 5 down vote accepted

I've had success with these packages :)

Hope it helps!

share|improve this answer
    
Thanks - that did the trick! –  Faisal Vali Mar 20 '10 at 16:59
    
installing from source is still buggy. this worked. –  Elzo Valugi May 22 '10 at 22:33

Ubuntu 8.10 is not supported any more so i would recormend upgrading it if you are still using it (since original question originates from jul-09). Ubuntu 8.04 (LTS) however is still supported 2 more year on server environment and couple more months on desktop.

share|improve this answer

dotdeb.org packages (as linked in the best answer) are now up to PHP 5.3.5 - worth checking the PHP posts on the dotdeb site for the latest info. Have just installed 5.3.5 on Ubuntu 8.04 LTS and looking ok so far.

share|improve this answer

well - most stable way is to stay with what distro provides.

2nd safest would be to use official backports, but it seems php 5.3 is not there.

otherwise you have to rely on your own [if you compile and build package by yourself or 3rd party contributors. quick googling returns this as one of repositories [ x86 only ] of php 5.3 for ubuntu 8.10 : http://tekla.art.pl/php-5.3-debian-ubuntu/

share|improve this answer
    
I could try compiling my own (have to learn it some time) but how will I prevent the rest of the system from complaining that the php5 package isn't there? –  Bart van Heukelom Jul 5 '09 at 12:45
    
if you follow for instance follow compilation instruction i linked to - you'll get ubuntu/debian package that replaces original php5. so for instance phpmyadmin [ or anything else that depends on php ] should not complain. you'll probably have to compile from source other php libraries that you might need [ php5-gd, php5-snmp and whatever else ]. –  pQd Jul 5 '09 at 13:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.