Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently installed qmail in one of my freebsd machines. But whenever I telnet to its port 25 from the same machine or from remote machine, i get instantly disconnected.

Trying 127.0.0.1
Connected to localhost.
Escape character is '^]'

and within a second, i get kicked off.It is not logging anything in /var/log/maillog,messages or qmail logs.

I am not able to figure out what is going wrong.

share|improve this question
    
Is there any firewall/load balancer or some other device between your machine and the SMTP server? –  Khaled Feb 15 '12 at 15:45
    
This sounds like it might be some funkyness with tcpserver (which IIRC wraps qmail's SMTP server). It's pretty hard to tell you more though - Have you recently made any changes to the service run file for qmail-smtpd? –  voretaq7 Feb 15 '12 at 16:32
    
Can you give any more details about your installation? Did you use any patches to add functionality? What is your run script ? Also qmail-smptd log should at least log the connection. Can you see that ? –  thanosk Feb 15 '12 at 16:49
add comment

2 Answers 2

qmail shouldn't work. it is ten years out of date and flouts the standards.

share|improve this answer
1  
OP should look at this: shearer.org/MTA_Comparison or, "OMG, why are you using qmail in 2012?" –  cjc Feb 15 '12 at 15:58
1  
Worse than that: 1.03 / June 15, 1998; 13 years ago –  Chris S Feb 15 '12 at 16:04
    
I was being generous ;) –  adaptr Feb 15 '12 at 16:19
    
I'm using qmail because it's working and I have no time to replace it. The amount of work required to fix it if something were to go wrong is insane -- If our mail server died (or really had ANY kind of a problem whatsoever) tomorrow I would NOT rebuild it with qmail. –  voretaq7 Feb 15 '12 at 16:28
    
i cannot change it ....it has been our standard... any idea what could be wrong going on ? –  Sangfroid Feb 15 '12 at 16:32
show 2 more comments

Qmail by default is out of date. Do not run it from source without patching the source or you will be a spam relay instantly. If you want to run Qmail, I suggest you find a packaged, community supported project like Qmailrocks or Qmailtoaster.

John Simpson has added many important patches to Qmail that you will need to think about. You can find his site on qmail at http://qmail.jms1.net/.

share|improve this answer
    
In a terminal: qmailctl stat if it is not running, use qmailctl start –  John Raley Feb 15 '12 at 19:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.