Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a PowerShell script that starts several external programs and batch files. All of calls worked fine on my Windows XP/PowerShell 2.0 machine.

On a Windows Server 2003/PowerShell 1.0, however, several of those resulted in an error "ERROR: operable program or batch file." for some reason. Some worked. Most resulted in the error.

What am I likely doing wrong?

share|improve this question
2  
Any reason not to update your 2003 machines to PowerShell 2? –  jscott Feb 15 '12 at 16:50
    
Yes. I cannot install software on the machines. I can only run scripts to configure one product on them. –  Andrew J. Brehm Feb 15 '12 at 21:56
    
FWIW - Based on this and other questions you've posted, I suggest you down-rev your local PoSH install (or build a virtual machine running v1) so you start getting consistent results. –  uSlackr Feb 21 '12 at 16:21
    
Alas this is not possible. Company has very rigid rules and won't allow such changes. –  Andrew J. Brehm Feb 21 '12 at 18:42
add comment

1 Answer

I'm going to guess it's not related to XP/2K3 or v1/v2. Double-check your PATH and that the particular external programs actually exist on the Server system.

That error message seems to imply that the external program doesn't exist (or more likely, we just don't know where it is due to PATH differences).

share|improve this answer
    
I think the error message is the last few words of something like "<name> is not an operable program or batch file" so something is apparently found. The programs do exist and can be started from the command line outside the script. –  Andrew J. Brehm Feb 21 '12 at 7:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.