Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've downloaded memcache-2.2.6 and when i run:

phpize && ./configure --enable-memcache && make

I get:

Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626

This is correct but after configure, make and adding the module to php.ini i get:

PHP Warning:  PHP Startup: memcache: Unable to initialize module
Module compiled with module API=20060613
PHP    compiled with module API=20090626

Edit: The php its not from the debian package, its a manually php 5.3.8 install

Thanks

share|improve this question
    
I assume from your tags this is debian. Is there a reason you don't just apt-get install php5-memcached? Are you not using php5 from the debian package? –  stew Feb 15 '12 at 19:27
    
No, its not from the debian package. I think i should specify that. Also i am using the phpize from the php folder. –  keepwalking Feb 15 '12 at 19:29

3 Answers 3

If you cannot use pecl, you can also specify the proper path to your php config in the ./configure command (use if you have multiple versions of php installed.)

./configure --with-php-config=/usr/local/php53/bin/php-config
share|improve this answer

why not just apt-get install php5-memcache or apt-get install php5-memcached (or both) depending on whether you need memcache or memcached and not bother with compiling?

share|improve this answer
up vote 0 down vote accepted

It looks like using pecl install memcache installed the correct memcache module version.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.