Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

---- edit: Problem solved. Somehow my provider seems to block tests to the internet. Tests from a remote machine succeeded with 1k r/s ---

I am running a fresh compiled version of Apache 2.2.1 on ubuntu 10.04.03 LTS. The root-server has 32GB RAM and is a i7-2600k. The about same hardware and software is available for testing inside a virtual box on the intranet.

While the test server works great, serving about 800 concurent transactions/sec the "real" server on the internet just serves about 15 transactions per/second.

Running siege against it with: sudo siege -b -c50 -d10 -i http:/... the server starts serving files OK, but then after about 20-40s it gets slower and slower until it gets almost a halt.

unix top shows the apache process starting to span, but soon they ALL disapear, while the system only is running on load average of 0.1 - 0.3 Almost no resources are used. The process eat about 0-1% CPU.

configuration of httpd.conf is about the same as on the test server. I also tried to change some values that make sense but that did not help.

After experiencing the same problem with nginx I did run a network benchmark with netperf that returned from a remote location successfully 600MB/s, but from the intranet only 0.13MBs

Does anybody have an idea how to aproach that problem. I am maintaining linux systmes no for 10 years and have never seen something similar before.

Thank you for any help!

share|improve this question

With the curiosity of why you've chosen to compile instead of using a prebuilt package for your environment, have you ensured that you have swap enabled on the system? If it were RHEL, you should have physical+2G swap (34G in your case).

Are any odd plugins or unusual mod_* items configured and running (java, etc)?

The most probable area to look at in my opinion I to ensure you've compiled the package properly (or use one from a public repository for your platform), and make sure swap is configured correctly.

share|improve this answer

It sounds to me like you have a duplex mismatch somewhere in your network. You have a switch hard set to full duplex which turns off the duplex negotiation protocol and a server set to auto-negotiate duplex. When it doesn't get an answer back from the switch, the server defaults to half-duplex, resulting in a mismatch. This will cause the horrid network performance you're seeing.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.