Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a windows server 2008r2 running IIS 7.5. I am trying to setup a FTP-server in IIS but I'm running into some annoying problems.

Setting up the server works fine but when I try to connect from a remote client the connection times out. I have tried to connect to the FTP-server from the localhost and it works flawlessly.

I figured that it should be some trouble with the firewall so I went into firewall settings and disabled the Public Profile and my remote connections worked!

In my inbound rules there are rules for FTP-connections to allow all profiles etc. I guess they are made automatically when setting up the FTP-server.

Anyone got any idea how to allow remote connections without turning off the public firewall?

share|improve this question
If you use active FTP, create an additional FW rule, allowing inbound tcp-connections on port 20 as well – Mathias R. Jessen Feb 15 '12 at 21:39
As Mathias suggested created a rule for port 21 in the Windows Advaned Firewall coniguration manager. This should get you started – RomeNYRR Feb 16 '12 at 18:15
There is already an inbound rule which allows traffic on port 21. I also tried to open up port 20 but that didn't do any good. – nbon Feb 17 '12 at 8:36

can you show the relevant rules with command

netsh advfirewall firewall show rule name=all

what you basically want is for active ftp ports 21 incoming (from any port), and port 20 (data) outgoing to any port. For passive ftp, you'd need to allow incoming ports of the given range (set up on IIS) and allow them in the firewall too.

have a look at this guide Configuring FTP Firewall Settings in IIS 7 i think it'll be very helpful.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.