Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am configuring Solaris 11 on x64 as a test bench for a home storage system.

I cannot enable smb/cifs share> zfs set sharesmb=on It says "protocol not installed" Where do I find this missing component and how do I install it? Thanks a lot, Dan

share|improve this question

I don't know why, but the new solaris 11 does not include smb protocols by default. You must find smb packages from one of the repositories and install them yourself. So, to get your smb protocol up and running:

  1. Install service/file-system/smb, system/file-system/smb via pkg command or the package manager interface.
  2. Update /etc/pam.conf to include the line "other password required pam_smb_passwd.so.1 nowarn".
  3. Reset your smb user's password (to the same one if needed) by using "passwd your-user-name-goes-here".
  4. Enable service using the command "svcadm enable -r smb/server".

Make sure to include the -r option. Without it, the dependencies do not start with the smb service.

share|improve this answer
    
Just a a clarification on what's installed and what isn't. Both service/file-system/smb (server) and system/file-system/smb (client) are part of a default Solaris install. Take a look in your global zone. However the service/file-system/smb pkg is not part of the local zone manifest and therefore by default doesn't exist for a plain vanilla zone install. You'll have to install it explicitly if you need it inside a local zone. I suspect this was true even in 2012 when this answer was written. – peterh Mar 19 at 13:53

Thanks Dae, They've updated the instructions a bit for Solaris 11 UI, the line in /etc/pam.conf is now:

password required       pam_smb_passwd.so.1 nowarn

And you also have to call:

sudo smbadm enable-user [username]

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.