Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using Tomcat7 on Windows Server 2008

My Server.xml is set up as follows:

<Connector port="80" protocol="HTTP/1.1" connectionTimeout="20000"
compression="on"   compressableMimeType="text/html,text/xml,

<Connector port="443" maxThreads="200" protocol="HTTP/1.1"
scheme="https" secure="true" SSLEnabled="true"
keystoreFile="C:\program files\java\jre7\bin\tomcat.keystore"
keystorePass="password" clientAuth="false" sslProtocol="TLS"/>

<Connector port="8009" protocol="AJP/1.3" redirectPort="443" />

However when I go to or then no page is displayed.

If I do a search and replace, changing port "80" for "8080" and port "443" for "8443" then my website works perfectly, although I need to access it via and

I would like access to the site to be without having to specify the port numbers!

share|improve this question

Are you running IIS on the same machine? Could be that IIS is consuming TCP ports 80 and 443. You can view all open TCP ports via CMD command: "netstat -at"

share|improve this answer
Comment to Sven: Thank you... IIS is not installed on the server, and nothing else seems to be using using ports 80 or 443. (after checking with netstat -at) – gordon613 Feb 16 '12 at 16:29
I neglected to mention that this machine is a cloud server. Is it possible the cloud mechanism is getting in the way somehow? – gordon613 Feb 16 '12 at 16:30
up vote 1 down vote accepted

The answer is very simple! The ports 80 and 443 were blocked on the Firewall. I unblocked them by using the following [deprecated] commands from the command line:

netsh firewall set portopening tcp 80 smb enable 
netsh firewall set portopening tcp 443 smb enable 
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.