Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a NLB cluster that has been setup for several months and everything is working as expected.

After a reboot of one of the nodes I no longer see that node in the NLB manager. It says it's "Loading information from host "hostname" for cluster "cluster name" but it never comes up as a node in NLB manager.

However the node is still participating in the cluster. It is accepting traffic, and if you do an ipconfig it lists the cluster IP address.

This is on a pair of Windows 2008 R2 servers and the cluster mode is Multicast. The only event log entries I get are saying the nodes have converged as expected.

How can I resolve this situation?

share|improve this question
1  
OS? Hardware? Network configuration? Multicast enabled? Log events? –  Mathias R. Jessen Feb 17 '12 at 1:55
    
@MathiasR.Jessen thanks for the reminder, I updated the question. –  Steve Evans Feb 17 '12 at 17:22

1 Answer 1

I would take a look at the layer 2 to make sure the NICs that aren't part of the NLB can see one another. If memory serves, the nodes will converge over the NLB NICs, but all management, including the NLB Admin console on one querying the other, will occur across the NICs that are not part of NLB. Check your binding too, to make sure Client and Server services are not bound to the NLB, unless of course, it's the server service that is serving what you are trying to load balance, and that the physical ip.addrs of the NLB NICs are not registering in DNS and/or WINS. If these are virtual boxes, check to make sure after reboot you didn't get migrated to a different host from what you were on pre-reboot, and if VMware, that IP hashing is the load balance algo on the vswitch. HTH

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.