Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


I have Bugzillla 3.6 running on Linux, with a Windows 2008 server for our internal DNS.

I need to set Bugzilla's urlbase" so the SAME configuration will work for INTERNAL clients (EX: http://bugs.local/bugzilla) as well as EXTERNAL clients (EX:

  • External works OK: I configure urlbase to "", and I'm able to log in to Bugzilla from outside our LAN with no problem.

  • Internal doesn't work at all unless I hack :

  • WORKAROUND: notepad c:\windows\system32\drivers\etc\hosts =>

Q: It seems that urlbase requires a fully qualified domain name (e.g.

I absolutely cannot use one FQDN for both external clients ( and internal clients (bugs.mycompany.local).

Is there ANY "one size fits all" option for Bugzilla's "url_base"??????????????

share|improve this question
up vote 0 down vote accepted

There is no option such as this. If it were possible to configure more than one URLbase, Bugzilla could only know which one to send to a particular client by knowing the details of your internal network - what is an internal IP, and what is an external IP.

The correct fix is to set up your internal company DNS servers to return the value "" when asked about "". Then the Right Thing will happen, and you don't have to edit /etc/hosts on every machine.


share|improve this answer
Hi - thank you for the answer. Unfortunately, that's absolutely not the right thing in Microsoft-land: they expect you to distinguish between "mycompany.local" (internal) and "" (external), then the Microsoft client stack should be configured to look for "bugs" as "bugs.mycompany.local" first. All of which assumes the client is in an Active Directory environment and all the clients use Microsoft Dynamic DNS. Sigh... I do appreciate the response. – paulsm4 Feb 18 '12 at 2:20

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.