Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to restore a .bkf file created on SBS 2003, to a SBS 2011. I have downloaded and instaled restore utility, but I am getting this error

Unable to write data to c:\foldername This security id may not be assigned as the owner of this object

This is not happening to all files and directories, and I would like to know how to solve this problem? I have added user as as member of Backup Operators , but that did not solve the problem.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

First things first, try to start the utility via right-click, 'Run as Administrator' and see if that resolves the issue. With UAC & server 2008, all administrator accounts except for the original 'default' administrator account actually run as a standard user and require elevation. Other options to try are to disable UAC (not recommended), or browse to the folder via the admin network share (\servername\c$\foldername) when setting the output path in the Restore utility.

If I recall correctly, the SBS2011 setup makes you create a secondary/new administrator account as a best-practice thing, so you will probably run into this a lot when dealing with folders, especially with one at the root of C:.

Some more info (written for Win7, but applies): http://think-like-a-computer.com/2011/05/11/windows-access-denied-folder-administrator/

Hi, Start from Windows Vista/Windows 2008, UAC is added which help increase the security level. If UAC is enabled, all accounts belong to Administrators group (except Administrator account) are actually running as a standard user. They have permission to "run as administrator" when need to access/modify system files and/or registries. Thus if we only add Administrators in NTFS permission, only Administrator account can access the file without "run as admin". The workaround is to disable UAC (not recommanded) or create a new group with all administrator accounts and add the group to NTFS permission as well.

Per: http://social.technet.microsoft.com/Forums/en/winserverfiles/thread/1ea6cdc7-1e19-48e0-961e-96dfd0f13ed0

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.