Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I'm trying to install phusion passenger on my CentOS server on Media Temple (dv4). However, I have 3 missing dependencies when trying to install httpd-devel.

--> Missing Dependency: httpd = 2.2.3-53.el5.centos.3 is needed by package httpd-devel-2.2.3-53.el5.centos.3.i386 (updates)
httpd-devel-2.2.3-53.el5.centos.3.x86_64 from updates has depsolving problems
--> Missing Dependency: httpd = 2.2.3-53.el5.centos.3 is needed by package httpd-devel-2.2.3-53.el5.centos.3.x86_64 (updates)
Error: Missing Dependency: httpd = 2.2.3-53.el5.centos.3 is needed by package httpd-devel-2.2.3-53.el5.centos.3.i386 (updates)
Error: Missing Dependency: httpd = 2.2.3-53.el5.centos.3 is needed by package httpd-devel-2.2.3-53.el5.centos.3.x86_64 (updates)

Seems like I'm missing httpd=2.2.3-53.el5.centos.3, but I have no idea how to find out what's the current version I have, and how to update it.

share|improve this question

migrated from webmasters.stackexchange.com Feb 18 '12 at 22:51

This question came from our site for pro webmasters.

    
Hi there, OS questions are generally best off asked at serverfault. –  toomanyairmiles Feb 18 '12 at 18:26

1 Answer 1

you have mixed 32 and 64 bit libs installed, sometimes the devel libs conflict because they want to install files that are common to both the x86_64 and .i386 version. (and presumably having 2 httpd packages would conflict because they want to listen on the same port, but I have not tried that...;-)

start by trying to install either the 64 or 32 bit dependencies, so help the phusion installer.

yum -y install httpd-devel.x86_64 httpd.x86_64

if that doesn't work you should look to try to install the correct passenger by passing the arch.

yum -y install mod_passenger.x64_64
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.