Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a CentOS server which runs few web sites. Suddenly all the web sites stopped functioning and when I check that I noticed that MySQL Service is down. I am new for this server related things. I executed following commands on WebMin since I have access for that.

> /etc/rc.d/init.d/mysqld start
bash: /etc/rc.d/init.d/mysqld: No such file or directory
> service mysqld start
mysqld: unrecognized service

It's really strange since it worked today morning even. Can someone help me in fixing this issue.

Thank you.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

This looks like MySQL has been uninstalled

Check that:

rpm -qa | grep mysql

returns something like

mysql-server-5.0.77-4.el5_6.6
mysql-5.0.77-4.el5_6.6
share|improve this answer
    
These are the things I get for this command. mysql-libs-5.1.52-1.el5.remi php-5.3-pdo-mysql-zend-server-5.3.8-17 php-5.3-mysqli-zend-server-5.3.8-20 php-5.3-mysql-zend-server-5.3.8-18 mysqlclient15-5.0.92-1.ius.el5 Nobody uninstalled the MySQL that's why I am really confuse about this. –  Prasad Rajapaksha Feb 20 '12 at 1:07
add comment

I ran into a similar issue where MySQL service had gone down after some updates. The solution for me was a permissions issue with mysqld. The limited permissions did not allow mysqld to be executable. Try something like:

$ chmod 755 mysqld
share|improve this answer
add comment

I had to install mysql and mysql-server on my centos box:

yum install mysql mysql-server
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.