Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to setup two static ip networks with vlan. I have created vlan0, vlan1 and vlan2 in my linksys WRT54GS router with DD-WRT.

vlan0 setup
ip address: 192.168.1.10 ~ 192.168.1.30    (20 computers)
subnet:255.255.255.0. 
Default gateway:192.168.1.1
DNS server: 192.168.1.156

vlan1 -> WLAN

vlan2 setup
ip address: 192.168.2.2 ~ 192.168.2.5   (4 computers)
subnet:255.255.255.0. 
Default gateway:192.168.2.1 **(not sure what to do here)**
DNS server: 192.168.1.156  ***(not sure what to do here)***

The networks work fine except vlan2 computers have no internet access. I would appreciate anyone would help me about this issue. Thanks.

UPDATE:

Please see my settings below.

www.parkerandassociates.org/vlan.JPG

http://www.parkerandassociates.org/network.JPG

share|improve this question
add comment

1 Answer

For VLAN2, the gateway and dns server should be on the same network as your computers (192.168.2.x). You need to enter the IP address of your router on that network.

In a very common setup, you'd need to make sure your router has an IP address on that network (i.e. 192.168.2.1) and use that as 'Default gateway' and 'DNS server'.

In your case, you seem to be using a different DNS server... If so, you can use 192.168.1.156 as DNS server in VLAN2. Your router should also know how to forward packets between the two networks (192.168.1.x and 192.168.2.x) but this is done automatically by many routers when you assign them an IP on each network.

share|improve this answer
    
TY jjmontes. Please see my updated pictures above for my settings. I am not sure if my router would forward packets between two networks. I do have my default gateway set as 192.168.2.1 and dns server as 192.168.1.156 on my vlan2 computers. still no internet access on vlan2. Please help. thanks again. +1 –  Jerry Feb 19 '12 at 21:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.