Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a development server that I'm trying to enable a self-signed SSL on so that we can test some functionality specific to the SSL before pushing out to our production server (which has a real, certified SSL)

I first tried to use the Self-Signed Certificate feature inside IIS 7.5, but that didn't work. I was looking around and found that IIS manager doesn't set the IssuedTo to the domain of the site, so I tried doing that.

I found this walkthrough (http://www.robbagby.com/iis/self-signed-certificates-on-iis-7-the-easy-way-and-the-most-effective-way/) and tried it, but it still wasn't working. When I try to access the site via https, it can't find the site (Chrome returns "Webpage not available", Firefox returns "unable to connect"). That tutorial looks to be correcting the issue of whether the cert is trusted or not, but I can't even get mine working at all.

I'm not sure if this could be some sort of network issue at our hosting provider or what. We have full control of the server via RDP to make any changes necessary on the server itself, but I don't know where to start looking for what's wrong with this.

Just for reference, we have numerous sites set up on this development server, including review.site.com and stage.site.com. I am trying to set up the SSL for stage.site.com. The production site (www.site.com) is hosted on a different server within the same network as the dev server.

Any ideas on where to start looking for this?

share|improve this question
    
Can you access the sites over SSL (https) on the local machine? –  Mathias R. Jessen Feb 20 '12 at 16:36
    
When you browse to the site on the server do you still get "Webpage not available"/"unable to connect". You did configure the bindings on the site to use your SSL? One other thing, use the SelfSSL tool but make sure your keysize is at least 2048 bits (/k:2048). –  Kev Feb 20 '12 at 17:06
    
@Mathias/Kev: when I try to navigate to the sites on the local box (using IP address. e.g. 999.999.999.999:443), it redirects me to port 80 without SSL. @Kev: I will have to try setting the key size. I did not do that before when using SelfSSL tool. Why would that help anything though? –  jwynveen Feb 20 '12 at 17:12
1  
Ok...don't browse to your site on http://.....:443, just browse to https://.... https signals to the browser that you want SSL (over port 443). RE: key size - I wondered if your machine had been PCI locked down (disabling weak cyphers etc) but could be a red-herring. –  Kev Feb 20 '12 at 17:46
    
Navigating without the port number seems to work. And it technically works with the port number too (it removes it), but I was initially testing with a page that redirects to http automatically. So since it works locally with the IP, what could be preventing it from working externally (or locally) via domain name? –  jwynveen Feb 20 '12 at 18:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.