Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try and bind a Mac running 10.7.3 to a Windows 2008 active directory using System Preferences and Directory Utility. It comes back saying "Unable to add server. Node name wasn’t found. (2000)”. What does this mean? Can anyone help?


share|improve this question

I managed to fix it. Here's how:

  • set the client's time to the network time from the windows server
  • deleted the computer account off from the Active Directory
  • restarted the Mac client!
  • tried fine

Not really sure what was causing the problem, but it's now working. Thanks for the input!

share|improve this answer
Glad you've got it working. Please be sure to mark this answer as "accepted" when you are able. – jscott May 28 '12 at 3:21

I had similar issues and resolved it by doing the following: - ensured the mac's time was the same as my domain controllers (i have NTP servers so i used that). kerberos will not tolerate anything greater than 5 minutes skew in time! - updated to the latest apple OSX updates. I was on 10.7.3 and 10.7.5 had significant Active Directory bug fixes.

that's it, worked first time after that. i'd like to point out that i did not create the computer object first, it was created upon joining the domain. Also i just typed in my adminisrative username not domain\username.

Hope this helps someone else.

share|improve this answer

to paraphrase Monty Python: I have to clear the PRAM a lot.

I've found this fixes a number of binding/login issues when a computer that was joined to AD previously is re-imaged with 10.8, then re-joined to AD. (very slow login for network users, or anomalous errors when you try to join AD, etc)

share|improve this answer

I've seen this in Snow Leopard when the OS X client has a strange name. Do you have anything other than letters, numbers, and underscores/dashes in the OS X machine's name? If so, you'll have to remove them before binding to AD. Also, you should make sure that the name is 16 characters or less, though this seems to be less of an issue nowadays than it used to be.

share|improve this answer

I think the time issue is key, I came across that one before and forgot the solution until I found this post (whilst trying to get another MacBook on the domain). If the time is too far out (in our case it was 20 minutes out) the domain controller will have none of it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.