Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've recently made a server (it's a VPS hosted on a2hosting) by following these instructions: http://www.howtoforge.com/perfect-server-centos-6.0-x86_64-ispconfig-3 All is working well, except for the DNS.

These are my current settings on ISPconfig

http://mjzone.net/Files/dns432r3.png

(toss is supposed to be a subdomain)

I'm experiencing several issues with this:

1) by using the dig command i can retrieve only the mjzone.net record (which is also the only working URL), nothing else works (not even www.mjzone.net). This is the result of dig www.mjzone.net

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> www.mjzone.net

;;global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36620

;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:

;www.mjzone.net. IN A

;; Query time: 35 msec

;; SERVER: 69.39.86.5#53(69.39.86.5)

;; WHEN: Tue Feb 21 00:50:38 2012

;; MSG SIZE rcvd: 32

While this is the result of dig mjzone.net

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> mjzone.net

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33910

;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:

;mjzone.net. IN A

;; ANSWER SECTION:

mjzone.net. 1800 IN A 75.98.171.57

;; Query time: 63 msec

;; SERVER: 69.39.86.5#53(69.39.86.5)

;; WHEN: Tue Feb 21 00:53:46 2012

;; MSG SIZE rcvd: 44

2) using the dig command by specifing the nameserver (dig @ns1.mjzone.net www.mjzone.net) gives me this error "dig: couldn't get address for 'ns1.mjzone.net': not found" while using dig @mjzone.net gives me all the records i set up on ISPconfig (even those that don't work, like dig @mjzone.net toss.mjzone.net or dig @mjzone.net www.mjzone.net)

; <<>> DiG 9.7.3-P3-RedHat-9.7.3-8.P3.el6_2.2 <<>> @mjzone.net www.mjzone.net

; (1 server found)

;; global options: +cmd

;; Got answer:

;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 57333

;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 2, ADDITIONAL: 2

;; QUESTION SECTION:

;www.mjzone.net. IN A

;; ANSWER SECTION:

www.mjzone.net. 86400 IN CNAME mjzone.net.

mjzone.net. 3600 IN A 75.98.171.57

;; AUTHORITY SECTION:

mjzone.net. 3600 IN NS ns1.mjzone.net.

mjzone.net. 3600 IN NS ns2.mjzone.net.

;; ADDITIONAL SECTION:

ns1.mjzone.net. 86400 IN A 75.98.171.57

ns2.mjzone.net. 86400 IN A 75.98.171.57

;; Query time: 0 msec

;; SERVER: 75.98.171.57#53(75.98.171.57)

;; WHEN: Tue Feb 21 00:57:06 2012

;; MSG SIZE rcvd: 130

3) at the moment there exist these URL: toss.mjzone.net.mjzone.net and www.mjzone.net.mjzone.net created by a wrong configuration (i made www.mjzone.net and toss.mjzone.net A records in my early attempts to configure the DNS) and they got memorized on the server (and they still exist though it's been more than 3 days i've deleted them), so i can't tell if it's a misconfiguration problem or that the DNS haven't been updated yet.

What do i have to do to make this work?

Should you require more informations i'll be glad to give them

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The whois entry for that domain is currently pointing to dns1.name-services.com through dns5.name-services.com.

To manage the DNS for the domain on that server, you'll need to modify the whois information via your domain registrar with the correct authoritative servers (ns1.mjzone.net) and glue records for those systems.

share|improve this answer
    
I've just discovered (shame on me) that on my hosting there's its own dns management page in the domains control panel. Before moving to a non-managed VPS i was using a managed VPS (which had cPanel, and i hadn't got root access), when i modified something on the cPanel's DNS editor it just worked, so i assumed it was the same here, looks like i was wrong. I'd never realize that without your answer, thanks –  valepu Feb 21 '12 at 1:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.