Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've tried 3 different systems including VMWare with very same Ubuntu 10.04 (Server Edition) basic installation.

  • Phisical computer
  • VirtualBox
  • VMWare

On first two, I am able to easily change console resolution(not grub resolution) by altering /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
GRUB_GFXMODE=1024x768
GRUB_GFXPAYLOAD_LINUX=keep

Then of course sudo update-grub2; sudo reboot

However, with VMWare, GRUB_GFXPAYLOAD_LINUX=keep will result to blank screen (although based on windows size seems like resolution is set after bootup).

I've tried on 7.x and 8.0.2 versions of VMWare Workstation. So the question is, what special steps to be done in order to change console resolution on VMWare?

share|improve this question

Since these GRUB settings work with BIOS video modes, chances are that the VMware BIOS (a heavily modified Phoenix BIOS) does not support what you are asking it to do.

share|improve this answer

Does the VMWare Community entry Workstation 11 + Debian 8 = GRUB gfxpayload problem & blank screen help you?

Quoting the accepted answer there:

Try appending vmwgfx.enable_fbdev=1 to the kernel command-line and see if that resolves the issue.

share|improve this answer
    
Please note that this is a 3 year old question. You're unlikely to get a response from the original poster of the question. – Magellan Jan 8 at 12:07
    
I had noticed that ... I found the link while fixing a similar problem (blank screen when setting console resolution in VMWare), and it helped me. So maybe this can still save someone else Google'ing this issue some time -- even if OP has long since moved on. – Orangenhain Jan 8 at 16:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.