Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm based in the UK, and we have recently acquired VDSL FTTC Fibre optic connection. We are currently using the provider supplied VDSL modem and wireless router.

We want to use our Cisco 877 instead of the wireless router. Apparently we can't get around using the supplied VDSL modem. I've found configs on the internet for how to do this, but I cannot seem to get it to work. Effectively we've configured the router to use FastEthernet3 for the WAN connection, which is also configured with the PPPoE settings required. We're going to use FastEthernet0 to connect to our internal LAN, with NAT configured on these two ports.

Has anyone had any success with this, or am I attempting something which is not possible?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I've finally got it to work, here are the sections of my config which did it:

interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
 pvc 0/38 
  encapsulation aal5mux ppp dialer

interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
 switchport access vlan 101
!
interface FastEthernet3
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
 ip address 10.193.125.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 zone-member security in-zone
!
interface Vlan101
 no ip address
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip virtual-reassembly
 pppoe enable group global
 pppoe-client dial-pool-number 1
!
interface Dialer1
 description $FW_OUTSIDE$
 mtu 1492
 ip address negotiated
 no ip unreachables
 ip nat outside
 ip virtual-reassembly
 zone-member security out-zone
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp chap hostname 
 ppp chap password 0 
 ppp ipcp route default
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Dialer1 overload
!
ip access-list extended NAT
 permit ip 10.193.125.0 0.0.0.255 any
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.