Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I tried to install Glassfish 3.1.1 on windows with an installer but the Config Result - Creating Domain fails.

This is the error message:

Executing command :C:\glassfish3\glassfish\bin\asadmin.bat --user admin --passwordfile
- create-domain --savelogin --checkports=false --adminport 4848 --instanceport 8080
--domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
domain1

C:\glassfish3\glassfish\bin\asadmin.bat --user admin --passwordfile - create-domain
--savelogin --checkports=false --adminport 4848 --instanceport 8080 --domainproperties=jms.port=7676:domain.jmxPort=8686:orb.listener.port=3700:http.ssl.port=8181:orb.ssl.port=3820:orb.mutualauth.port=3920
domain1 The system cannot find the path specified.
share|improve this question

1 Answer 1

I had this problem and solved it:

1.Go to asenv.bat file in Glassfish config directory

2.modify line: set AS_JAVA="C:/Program Files(x86)/Java/" to point to your JDK (not JRE!) installation 3.retry asadmin command

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.