Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an svn set up on Debian 6

I have access on http://myserver/svn/youfood/, I can checkout from Netbeans but when i try to commit, still from Netbeans, i have these errors :

Netbeans Log

svn: OPTIONS of '/svn': 403 Forbidden (http://myserver)

Apache Log

[error] [client x.x.x.x] The URI does not contain the name of a repository. [403, #190001]

Here's my differents conf :

mods-available/dav_svn.conf

56 <Location /svn>
57         DAV svn
58         SVNParentPath /home/svn
59         AuthType Basic
60         AuthName "Subversion Repository"
61         AuthUserFile /etc/apache2/svn.passwd
62         AuthzSVNAccessFile /etc/apache2/authz
63
64         Require valid-user
65
66         #SSLRequireSSL
67 </Location>

sites-available/youfood

[...]

43     # SVN & TRAC
44     <Location /svn>
45         DAV svn
46         SVNParentPath /home/svn/
48         SVNAutoversioning on
49         AuthType Basic
50         AuthName "Subversion Repository"
51         AuthUserFile /etc/apache2/svn.passwd
52         Require valid-user
54     </Location>
55
56     <Location /trac>
57         SetHandler mod_python
58         PythonHandler trac.web.modpython_frontend
59         PythonOption TracEnvParentDir /home/trac/
60         PythonOption TracUriRoot /trac
61         AuthType Basic
62         AuthName "Trac"
63         AuthUserFile /etc/apache2/svn.passwd
64     </Location>

/etc/apache2/authz

21 [groups]
24 dev = user1, user2, user3, user4
25 admin = user1
35
36 [/]
37 @admin = rw
38 * = r
39
40 [youfood:/]
41 @dev = rw
42
43 [/home/svn/youfood]
44 @dev = rw

Thanks for your help

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Netbeans is trying to commit to /svn, not /svn/youfood - something's not right there.

You can prevent the 403 on /svn by setting SVNListParentPath On.. but since it seems NetBeans wants to commit to there, you'll likely just get a different error. Can you try removing the working copy from NetBeans and checkout again from the correct URL path?

share|improve this answer
    
I did specify the correct URL path on my checkout (I enter this one : http://_myserver_/svn/youfood). During checkout config, I was able to see subfolders on this repo and choose the last revision that I made manually. Update seems to return no error, only commit is the problem :( And SVNListParentPath on dont changes anything –  Yaman Feb 22 '12 at 3:15
    
Well, it shouldn't have any knowledge whatsoever of /svn, and the fact that it's missing the trailing slash is significant too - it's behaving wrong, and the only thing I can think of is that it's got the wrong repository address stored somewhere. Try some different SVN client software, like Tortoise or just the command line client; that'll tell us whether the problem is NetBeans or the server. –  Shane Madden Feb 22 '12 at 3:26
    
Oh god, my bad I totally suck :D The problem didn't come from the repository address, it came from my checkout configuration. I let default configuration on "Local folder" instead of specify a destination folder (c:\youfood for example). It work now, sorry for wasting your time, let's pretend this is fatigue's fault :p Thx for your help ;) –  Yaman Feb 22 '12 at 3:36
    
Haha no worries - glad you've got it worked out. –  Shane Madden Feb 22 '12 at 4:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.