Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
sudo apt-get install subversion
[sudo] password for hwsui:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  subversion: Depends: libsvn1 (= 1.6.5dfsg-1ubuntu1~jaunty1~andersk1) but it is                                                                                         not going to be installed
              Depends: libapr1 but it is not installable
              Depends: libaprutil1 but it is not installable
              Depends: libmysqlclient15off (>= 5.0.27-1) but it is not installab                                                                                        le
              Depends: libneon27-gnutls (>= 0.28.2) but it is not installable
              Depends: libpq5 (>= 8.3~beta1) but it is not installable
E: Broken packages
share|improve this question
You really should upgrade. 9.04 is no longer supported. – Zoredache Feb 22 '12 at 9:03
You can try to do apt-get update before installation... But I agree with @Zoredache, you should upgrade as soon as possible. – Jan Marek Feb 22 '12 at 9:19

Ubuntu 9.04 repositories have been burned from the primary Ubuntu mirrors - you will have this same issue with anything you try to install.

To do any installing of packages or to upgrade to a newer release (which you really need to do - that OS you're running hasn't gotten a security update in nearly a year and a half), you must instead use the old releases mirror.

Modify your /etc/apt/sources.list to use these lines instead of the existing ones:

deb jaunty main restricted universe multiverse
deb jaunty-updates main restricted universe multiverse
deb jaunty-security main restricted universe multiverse

Then apt-get update. And really - upgrade.

share|improve this answer

As has been said in comments, Ubuntu 9.04 is not supported anymore, so you should really think of upgrading.

As for your current issue:

  • Make sure to run apt-get update before you install the package;
  • You are using a PPA (very likely, given the version of libsvn1 it tries to install). Get rid of it and try again.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.