Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I would like to install Google SketchUp using GPO, so that it installs automatically to client machines, at log on.

  • I have found the MSI package, and copied it to an accessible network share. \\server\MSI\GoogleSketchUp.msi

  • I have set a policy which uses the Computer Configuration/Software Settings object. It points to the MSI and is set to 'assign'.

  • The policy is being applied to the client, I have checked using gpresult.

However the software does not install at restart of the machine.

Am I missing a step? Does the software need to be installed in the network share or just contain the MSI?

Thanks.

share|improve this question
    
What are the permissions of the network share? –  MDMarra Feb 22 '12 at 13:53
    
What does the application event log say? There should be errors if the policy is applied but the software isn't installing. Usually the source is MsiInstaller. –  SonoIT Feb 22 '12 at 15:33
    
There was a checkbox on the deployment tab of the properties that was initially greyed out, which said "install at logon". Once i managed to get this working, it installed fine. –  joec Feb 29 '12 at 13:04

1 Answer 1

I'd bet that you don't actually have the proper permissions on the share. Since the SYSTEM account of the machine is doing the installation, the Domain Computers group (or any other group containing computer accounts) needs to have read permission on both the share ACL and the NTFS ACL.

If you do have the permissions set correctly, have you manually tried to install the MSI from the commandline using msiexec /i \\path\to\installer.msi /qn? If that command doesn't work, your GPO deployment won't work either.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.